New 3540 and DMA

hi all,

i am getting frustrated fighting to get dma enabled on my new drive… i tried the removing the ide driver which seems to work at first. basically what happens is i remove the ide driver (which also removes the dvd driver) then scan for new HW. after it finds the new ide, i can enable dma and it even shows it as the current mode. then, it finds “cd drive” and installs it. even after this step, i can check, and sure enough, dma is still active. but then thirdly, it finds “new nec dvd drive” and install it. after this phase, it kicks the current mode back to pio only even though the option is set to dma if available.

i have an ati board (asus pundit-r) and a p4 2.8G. the only bios options available for the ide part are “type” and “pio mode”. they are both set to auto and there doesn’t seem to be an option to turn the pio off there, the only options are auto and 0-4.

does anyone have any idea of how to work around this?

btw, my HD is on a SATA port and is actually the secondary master(shows as UDMA 6 in the hardware mgr). my DVD drive is the primary master and it’s jumpers are set to cable select.

could i ever use some help…

thanks

cory

guess i can’t just edit m own thread,

just thought of something else, don’t think this has anything to do with it, but when i run nero’s info tool, it shows no aspi laer installed. would this affect it and do i need to intall one? btw, i’m running XP MCE.

thanks again in advance!

Hi :slight_smile:
You can only edit > 30 mins after posting.
Aspi shouldn’t affect you. See piccies.
Have you updated drives f/w?
Motherboard bios update?


that was going to be my next post. i still have dvd firmware 1.01 and asus sucks for saying what is included in their bios updates. i have installed the lated stable bios, but there is a beta out. i emailed them to see if this could affect it. i was also wondering if the bios could be limiting it. in the options section in the bios for my secondary master(SATA HDD), there are options for dma type, but in the options for the dvd drive, there are only options for type and pio. (the spece for the drive in th ebios page do show dma functionality, there are just no selectable options).

do you think either of these could be the culprit?

it’s strange because the pio doens’t get forced until the dvd driver gets installed as “NEC 3540A…”

also, thanks for the aspi tip, i fogot to use the pull down menu :confused:

Hi :slight_smile:
Try taking a look here

thanks for the link. i tried the toggle back and forth b/w pio and dma to no avail. i’m starting to think the asus bios doesn’t like this drive. ( see the link below) i wouldn’t think dvd drive firmware would affect this but i’m not all that smart when it comes to these things. i’m really struggling here…

looking at this, it seems like this board may have problems with some opti drives. i wish someone could tell me otherwise :sad:

well, changing from one ide socke to the other on the main board did it. not only did it get out of pio but it was able to go to udma instead of word, etc.
i’ve heard other people mention that reconfiging the drive, whether from master to slave or channel to channel, and this time, it worked for me. it even gave me new options in my bios…

To be remembered… Resembles the KT133A issue…

Glad you solved you problem :slight_smile:

yup, thanks for all the help

congrat’s on solving the issue.
maybe your windows had your drive condemned to pio in that ide spot.
there’s an excellenet article about this here, might help some other people:

http://www.michna.com/kb/WxDMA.htm