NEW 2510A firmware 2.16 out!

I just compared both firmwares and although the strategy versions are identical, there are still lots of Bytes that differ, although several parts of both files are identical. But I’ll update my firmware thread anyways. :slight_smile:

I just upgrade with no problem.

Pulled my sohw-832 out my firewire encloser and put 2510a in after I flashed it from dos to 2.15 , using pcs ide cable. then I used the nec flasher with 2.16 to flash it in the encloser it worked fine testing with verbatim 8x now. will post scan soon.

Ok what I decided to burn was not full disk so I didnt want to waste my last verbatim 8x so I used ricoh R01 but 6x here is the scan

2510a 2.16 in firewire encloser.


Hi!

For all those, who can’t wait for a hacked version of 2.16, I did it:

Download it here!

It includes all relevant patches:

  • 2100@2500 (for use on all 2xx0 and their OEMs)
  • riplock removed
  • RPC1

Use the DOS flasher from TDB to flash it!
http://tdb.rpc1.org

@Legnerp

Nice one :bow:

I have my NEC in external USB2.0 case, can I update it succesfully with this new firmware ?

You can flash your drive with a windows flasher only, otherwise you’ll have to connect it to your normal IDE.

OK, just a quick one:
2.06 (2100@2500, riplock removed, RPC1, RITEK DL support!)
Windows flasher: http://herrie.rpc1.org/downloads/2x00/2510/2510206.rar
DOS: http://herrie.rpc1.org/downloads/2x00/2510/2510206d.rar

2.16 (2100@2500, riplock removed, RPC1, RITEK DL support, DL bitsetting!)
Windows flasher: http://herrie.rpc1.org/downloads/2x00/2510/2510216.rar
DOS: http://herrie.rpc1.org/downloads/2x00/2510/2510216d.rar

Ritek DL support :bow: :bow: :bow: :bow: :bow: :bow: :bow: :bow:

Many thanks Herrie :slight_smile:

Awesome Herrie thx so much for the RITEK DL support, I’m off to buy some discs woohoo!

Wow Herrie! :bow:

Nice to hear from you!
Many thanks for this one! :slight_smile:

Thanks again Herrie,

I assume the Windows versions results in the same firmware patch as the DOS versions :confused: ? The DOS version of the patched 2.16 didn’t want to flash on my drive but the Windows one was OK.

Cheers

i am having the same problem.

i was using 2.06 firmware, received an error when trying to flash to 2.16 in DOS, so i flashed back to 2.15 original firmware, tried it again and got the same error msg.

might give the windows version a try now.

-edit- the windows flash worked flawlessly, using 2.16 now :slight_smile:

the error i received when trying to flash in DOS was: ERROR: Image type mismatch.

Hi!

Yes it’s right!
Herrie, I think you forgot to change the second last byte from 35h to 31h.

Version 2.16 supports DL Bitsetting. My question is, does it support SL Bitsetting? I would really like to keep SL bitsetting abilities and won’t upgrade my firmware if I lose this capability. Thanks for your time.

Nope it doesn’t we need a new HP 520/530i firmware for that :slight_smile:

Hmm, does this firmware, 2.16 (2100@2500, riplock removed, RPC1, RITEK DL support, DL bitsetting!) support the NEC2500 with DOS flash?

I just tried to flash my NEC2500 which has NEC2510 firmware already on it and it says with the Dangerous Bro’s flasher: Error Image File Mismatch

This is the cmd I used:

nec2x00a -sec -mas -flash 2510216.bin

Just fixed the DOS-version should work now :slight_smile:

Thanks :stuck_out_tongue: