"New" 16x dvd-r media (mcc 03rg20) and my "old" Teac dv-w516g (b4s6)

vbimport

#1

Hi. First of all i’m new at this, and only investigated this matter because my Teac dv-w516g (firmware b4s6) won’t recognize the “new” 16x dvd-r media (mcc 03rg20, found on verbatim discs, for example) and won’t burn them - the drive stops at the lead-in phase, and doesn’t even start the burn process.

Since this media is not listed on teac’s medialist for my model, teac basicly told me to “duck off”…
So, i investigated a bit, and was wondering if the famous omnipatcher (or even some other tool) can be used to add this media type to my firmware so that i can burn the dvds (however, i only saw omnipatcher being used to change speeds, not add new media types, so i wonder…).

Why do i want to do this? Because i like Verbatim media (ritek tends to sell out prety fast), and most stores seem to only have this new media now, and not the old ones my drive can burn! So i was wondering if there is any way for me to continue burning dvd-rs.

Thanks.


#2

Teac dv-w516g (LiteOn 1633s?? i’m not sure :S) that drive cant write DVD-R x 16 so maybe FW dont include that kind of DVD … try maybe FW from

Sony.710A.BYX4
Memorex.F16.BWSE
LiteOn 1633S.BS41

or New FW for 1653s
1653S.CS0P.patched-cf-ledfix.txt

made backup before :S


#3

1653S.CS0P supports it @12x, the 1633 firmwares support just 8x.


#4

@Tug
u want burn DVD-R x 16 ? or burn them at 12 x ??? i dont understand =/ (i seeping 3h/day)

@ala42
I know that 1653s (DVD-R x12) ;] i only got problems whit understanding txt … F… Insomnia =/


#5

Use ala42s MCSE and DVD Identifier.Go here for it http://dvd.identifier.cdfreaks.com/

Copy&Patse Media code from DVD Identifier, load firmware into MCSE, then import media code into MCSE. Save firmware. There you go.


#6

Well, in this case, patching an old firmware not really ever working, dated 2004/09/21 and not supporting mcc 03rg20, makes no sense. Update or crossflash to a new firmware, e.g. CS0P, which already supports this media code.


#7

No, you’re right, i didn’t make it that clear. I know my drive can only burn -r @ 12X, and i just want to burn mcc 03rg20 @ any speed (12, 8, 6, 4, i don’t care), because right now i cant burn it at all! That media isn’t in the drive media list, so the drive gets confused: reports write speeds of 1X, 2X and 4X for that media (the slowest the drive can burn is 4X, so its really confused). If you try to burn, the process stops in the lead-in phase, because the drive freezes even before starting the burn process (and thus preventing windows from shutting down).

Should i do that, flash to CS0P instead of patching my model’s fw? I mean, isn’t CS0P desgined for newer models? Won’t it have any problem working with a different (older) hardware?

One other thing, since the *.rpc1.org domain is down, i’ve been having difficulty finding firmwares, namely the original b4s6 for my drive (i only have the manufacturer’s .exe, not the .bin). I wanted to have that around, in case something goes wrong :wink: . Does anyone have it, by any chance?


#8

@Tug,
One other thing, since the *.rpc1.org domain is down, i’ve been having difficulty finding firmwares, namely the original b4s6 for my drive (i only have the manufacturer’s .exe, not the .bin). I wanted to have that around, in case something goes wrong . Does anyone have it, by any chance?

You could always backup your own firmware (B4S6) using LTNFlash. Then you would have it in .bin format. Go to my site, in Tools section, download. There is also a readme for LTNFlash with detailed instructions on how to use.
Could you please send me the B4S6.exe file. Go to my site and use the link to send it to me. I would really appreciate it. :iagree: . Thanks.


#9

@The Black Wizard
you can extract the .bin file out of the .exe with XFlash-X.


#10

Ok, i’ll try that once i get home.

I tried xflash-x, but it didn’t recognize the exe. I only have the original from teac’s site: FWUPDVW516G01.EXE (This one is a sfx, the one inside is the one that does the flashing).

About patching/flashing, since i’m new at this, do you recomend the CS0P for my drive?


#11

yes, flash to CS0P: http://codeworks.cdfreaks.com/firmwares/1653S.CS0P.patched-cf-ledfix.rar


#12

So, i tried the CSOP fw, namely the 1653S.CS0P.patched-cf-ledfix-sonyid.exe file. And the result was a tremendous suc… misflash. :frowning:

I noticed something strange after the reboot, when the drive would only read the filenames, not even the icon information on the files, and would crash the explorer window.

So, while trying to flashback to the old fw:

  1. Tried ltnflash, but it reported error 040803 and couldnt flash;
  2. Tried flashfix on the original manufacturer .exe, it succeeds, but then the .exe also fails to flash;
  3. mtkflash 1.80 and 1.80c can’t even run the C command, they just stop there, so i didnt try the upload command.

Any suggestions? (besides buying a new drive, that is…)


#13

are there nvidia ide drivers installed on your system? if yes, remove them and reflash the firmware.

apply the “1653S.CS0P.patched-cf-ledfix.exe”


#14

Nvidia ide drivers, as in a motherboad with an nforce chipset? No, only nvidia video drivers, since my motherboad is a via.

And none of the patcher programs seem to work… i even tried the dos mtkflash program.


#15

have you tried mtkflash before the patched flasher?


#16

Uh-oh. No, i just assumed it would work. Big mistake, it seems…


#17

mtkflash does only work, if you hold the eject utton of the drive for ~5secs til the led flashs. so the drive can be identified by mtkflash.


#18

Here u have How To
http://club.cdfreaks.com/showpost.php?p=975704&postcount=273

Here u got B4S2.BIN FW for your drive
http://www.promusica.pl/projekt/B4S2.rar

good luck


#19

Yes, it worked! Thank you all for your info. “Press the eject for ~5 secs while the drive is powering up until the light flashes”… didnt read that one in the readme…hehe

Now that i have the drive working again (good thing i read the faqs and backed up the old fw and eeprom), i’ll call it a night.

I’m not giving up though. What could have gone wrong?


#20

packet writing software like InCD can cause problems while flashing.