New 1620, many problems

vbimport

#1

Yuk, things not going well with a new Benq 1620.

  1. All Benq programs are crashing out of Win2000. Firmware flashers, Booktype and Qscan all crash when loading or don’t load at all.

  2. Crappy burns. Drive came with B7L9 FW, I immediately flashed to B7T9 using WinDWFlash (Benq flasher crashes). Have since flashed back to B7P9. Here’s what the burns look like making a Datadisc:

Seems to me like the drive is not doing too well. It looks the same using TY T02 and/or MCC004 at 16x. Here’s the best burns I’ve gotten so far:

Tried booting to safe mode to re-flash the drive to B7P9 and then back to B7T9, but all Benq programs still crash in Safe Mode, and WinBWFlash does not see any optical drives at all in Safe Mode (Windows does see them)

Things are not looking good here for Benq in this stable. The program crashes alone are reason enough to RMA this drive. Any ideas will be welcome.

Here’s another TY T02 burned at 16x with B7P9:


#2

Sorry to hear that rdgrimes. With your knowledge, I can’t say much… but wait… in safe mode, flash with the exe ones (not the cvt).


#3

You might also want to check this thread http://club.cdfreaks.com/showthread.php?t=124972

I never got any problem flashing back and forth, but maybe the above thread works for you. good luck.


#4

Benq flashers all crash in safe mode too, cvt flasher doesn’t see any drives anyway.


#5

Definitely software conflicts, or…

Edit:
How is the IDE cable?
Burst rate in Nero CDSpeed?


#6

No s**t. But since they all crash safe mode, it would seem to be more than just software. I used to get NEC flasher crashes when I had a USB card reader pluggen in, but that’s not the case now. Also unplugged all firewire, I’m sure it’s some driver, but no other issues here whatsoever with any other software or flashers.
I can only flash in Windows with the cvt files.


#7

Sorry, I edited my post above.

Can you check the burst rate in Nero CDSpeed?
From the Nero scan it looks like your system is not stable.
You might want to swap IDE cable too.


#8

Burst rate checks at 24MB/sec.
There’s no system problems here, every other drive works great and so do all known burning programs and utilities.


#9

Only thing I’d suggest is to change the IDE cable and if that doesn’t solve it return the drive for a replacement. Looks / sounds / smells like you just happened to get one of the defective bunch. I wouldn’t know what else would be causing it, rd. :frowning:

One other thought popped into my mind. What about power supply issue? Is this replacing a current drive or being added into the mix with all the other drives? What size power supply? Could be time for an upgrade to that. Just a thought but I’ve seen PSU’s cause flakier things to happen.


#10

How about try the drive in another machine?
Sorry I don’t have anything else to say, assuming that you checked all basic things. That’s usually my last attempt…


#11

Have tried the drive on Firewire, and also as a IDE replacement for another burner, always the same.
Tried the back-flash to M9 - P9-T9, flashing in Windows with cvt files, still the same crap burns and all Benq programs still crash. Only thing I can figure is that there’s something wrong with the drive/firmware that cause to programs to crash when they poll the drive, but all other programs can see it and use it alright. IDE cable is the same one I’ve always used with other burners, it’s a quality cable.


#12

Hmmm, rd… only thing I’d suggest I noticed you said you tried the backflash to M9. It’s L9 that seems to be the magic cleaning firmware. See if you can run that flasher without the official flasher popping up with errors. If you’d get errors even with B7L9 then I’d say it’s a bad drive and needs to be replaced. :frowning: Sorry your venture into the world of BenQ’s hasn’t been very promising so far - all I can say is once you get worked out you won’t be disappointed in the drive.


#13

you might want to try flashing in dos mode with tdb benq dos flasher and cvt. also how about scanning the media you burned with benq in the benq. sometimes liteons will give awfull scans with the media burned in them and sometimes it will give decent scans. its definetely best to scan media burned with benq in benq.
also might help to give system specs and try different chipset drivers.


#14

You have BenQ not OEM/bulk, at least your firmware shows? I have problems with my DW1620, too, but it is OEM/bulk and came with G7L9 firmware. Updated to G7P9. Still burns like crap, similar to yours.

I think mine was manufactured Nov 2004 Malaysia, not sure, but I will rip it out and send it in anyway, as it really sucks. Will post in this thread when I have the exact Date & Place. No serial number, fscking bulk/OEM drives appear to have none.

Really disappointed about BenQ bulk ware atm. I hope this will become better when I have a new one (and will definitely get one with B7x9 = BenQ firmware - want my 2 years of warranty without any chance of losing it).

More later.


#15

DOS sounds like it’s worth a try, but there does not appear to be a cvt file for L9 available anywhere.
The .exe for L9 actually opened for me, but crashed when I tried to run it, that’s the farthest I’ve gotten with an .exe.

QScan will open about 1/2 the time and run, after telling me that it only supports Benq drives.

BTW, drive mfg in Oct 04.


#16

The Qscan not reporting to work is a sign of a bad flash I believe I encountered the same thing with my 1620 I had B7T9 running on it and it worked fine for almost everything except when I came across some CMC MAG discs then things started to get strange (errors burning etc) because I had burned these same discs just fine with B7P9 a while back, so I ran QScan and it said drive not supported to my surprise even though 1620 B7T9 was available from the drop down box, so at that point I downloaded B7T9 again from BenQ’s website and flashed it again.

After that the CMC MAG discs worked fine and QScan correctly detected the drive I cant think of any reason the flasher might crash even in safe mode, have you tried running http://www.memtest.org/ just in case its the systems RAM that might be at fault ?


#17

Several versions as EXE and CVT: http://dvdpro.club.st/firmware/BENQ_FW.htm but not L9, you are right :frowning:

Oct 04? Do you know where it was produced?

I would also recommend to
a) check memory with a testing program
b) look at chipset ide drivers if you have such
c) disconnect other devices from the same IDE cable
d) when it is alone, connect the drive to the “outer” connector so only the one in middle is unused (reflections on the cable… was important with scsi, but well, why should it not be valid for ide too somehow)
e) boot Windows to safe mode
f) maybe try to set the drive in bios to a lower speed mode for flashing.
g) use quality cable

As I read above, you already did / have several of these … Just ignore them :wink:

Sorry but I fear as long as you dont find anyone else who had and solved that problem, you are on your own.

Good luck.


#18

I will extract and mail it when I am home.


#19

ala42 > I’d like a copy of it also if you still have my e-mail addy. Thanks


#20

Retail box says “Made in Malaysia”.

Trust me, this system is rock solid stable, MS IDE drivers. (NForce2 board).
I’m beginning to suspect that the burn quality issue and crashing programs are not related, but who knows. The flasher program crashed before any flashing had ever been done.

My general thinking is that on a system that is otherwise solid, I don’t go re-inventing everything to make one dubious component work, the chances of creating more problems than you solve is high.

The only other utility that has ever caused crashes on this system is InCD.

Will wait for L9 cvt before proceeding in DOS. Would also like to have a tool for extracting these binaries myself. Does TDB flasher also save files?