Network and IP troubles

vbimport

#1

Hey,
I didn’t know where to put this, but I’m hoping one of you network wizards can help.
I use a Netgear RP614 router/switch, which has been trouble free. Recently I moved, and was forced to use my laptop for dial-up connection for a week or so. Prior to that, the laptop was running on the network just fine. Laptop is WindozXP. OK, so now that DSL is back online, the network seems to be running fine via a new DSL modem. (Actiontek), but the laptop will no longer log into the network and cannot get an IP address from the router. XP gives me an icon/exclamation in the taskbar that says “no connectivity”. The details state that the IP is 0.0.0.0. Rebooting everything has no effect, and XP is unable to repair. I tried uninstalling the network adapter on the laptop, ran ipconfig-release and renew, and nothing works. The router shows a green light.

From the router config:
Router: 192.168.0.1
Modem: 192.168.0.2
Main puter: 192.168.0.3

The laptop intermittently appears in the router config as 192.168.0.2 This is obviously a conflict, but rebooting the router does not fix it, so I’m guessing that XP is forcing this IP address somehow. The laptop should come up as 192.168.0.4 AFAIK, but will not. I run ZoneAlarm, and have all the needed IP address listed as trusted zones, so that shouldn’t be an issue.

If I recall right, the old modem did not have an IP assigned by the router, but the new one does.

HELP!


#2

Kill ZA and see if it helps.
//Danne


#3

Laptop shows it’s connected and running at 100Kbs.

Killing ZA has no effect. :a

If I select “details”, it shows the correct router IP but nothing else.



#4

What if you uninstall ZA, delete the NIC in device manager and reinstall TCP/IP?
ZA is known to goof around with the TCP/IP stack.
btw, have you tried another port on the router?


#5

I’m not sure you can uninstall TCP/IP in XP. The repair function is intended to fix a corrupt IP stack. Have you tried assigning a static IP to the laptop?


#6

Tried next port, uninstalled ZA, deleted NIC, no joy.
No way to remove TCP/IP as far as I see, it goes away when the NIC is removed.

How do I manually assign an IP? That’s the error I get; “unable to acquire IP”


#7

typically DSL modems act as routers, and attempting to put routers behind them can cause issues. Your answer is probably to place the modem into “bridged” mode so that it will allow the router to route traffic, etc. Only issue with this could be that you would have to put your pppoe password into your modem’s config.

Other than that, I’m stumped. Do you not have any other devices to test with?


#8

I meant pppoe into the router’s config


#9

My desktop is working just fine. Although the IP conflict did throw the whole works out one time, rebooting everything fixed that. I’m typing on the connection now.

How do I manually set the IP on the laptop?


#10

My bad, looks like it’s not possible to reinstall TCP/IP just restore the settings in Windows XP. I suppose SP2s firewall is disabled?
//Danne


#11

From the router config:
Router: 192.168.0.1
Modem: 192.168.0.2
Main puter: 192.168.0.3

I’m a bit baffeled here.
Why would the DSL modem be assigned an IP address by the router if it’s on the WAN side?
The 192.168.0.1 is the router’s physical address and the 192.168.0.3 is the address assinged to your main computer by the router’s DHCP server.
The DSL modem should reflect the IP address assigned to you by your ISP and be displayed on the router’s Basic Settings under Internet IP Address. This would not be a 192.168.0.xxx number.


#12

It may be so that the modem has one port and NAT is already active instead of bridge mode.
//Danne


#13

OK, the problem is between the router and modem. It’s not the laptop, it’s ANY second computer that gets connected.
Qwest refuses to support any networking. :a :a They will not tell me how to set the modem or router to allow them to work together. Looks like I’m back to Comcast, who’s modem does work with my router. Rats. My interpretation is that both the modem and router are trying to act as DCHP, and the second computer gets assigned the same IP as the modem by the router. I’m pretty lost in all this IP stuff. :sad: If the modem had more than one port, I could use that I suppose. But it doesn’t.


#14

Both the modem and router handle DHCP… The modem via DHCP issues an IP to the router. That IP is on the ISP’s subnet (Example: 24.65.161.12). No other network devices can see this routable address… So now the router can talk to the Modem. In turn, the Router has an internal non-routable IP (Example: 192.168.1.1) which it assigns addresses on this subnet (Example: 192.168.1.10) to network machines and devices. Now the machines talk to, and only to the router at that subnet. Once you succesfully get an address from the router you can verify it by going to a command prompt and typing “ipconfig /all”, it should return something like this:

IPAddress 192.168.1.10
Subnet 255.255.255.0
Gateway 192.168.1.1 (Same as router’s address)
DNS Primary 24.29.161.147
DNS Secondary 24.29.161.148

If it returns this, then the machine should now be on the net.

This assume that your cable/dsl modem connects directly to the router via ethernet, not to the computer via usb.

If I can help, don’t hesitate to PM me…

Regards:

Edit: Since all devices need their DHCP assignment prior to issuing an IP to their child, the system requires devices started in a particular order.

  1. Powerup Cable Modem, allow time for to establish a link with the ISP’s network.
  2. Powerup Router, allow it time to get it’s IP from the Modem
  3. Fire the machines, all should be well…

#15

rdgrimes: Are you up and running yet?


#16

As I get it…

ISP --> Modem --> Router --> LAN (Computers)
It doesn’t matter whether WAN (anything outside the router) works or note, he should still receive a DHCP loan by the router unless he has deactived DHCP or killed the routers routing capabilities. This is btw not Qwests or for that matter any ISPs issue so I don’t see why they should have support for it. btw, if the modem have NAT enabled connect it to LAN 1 instead of WAN on the router or disable it and use the WAN port. If you can’t receive an DHCP loan from your router (assuming it’s correct setupped) I’d say that something regarding TCP/IP is fuddged on your laptop unless another computer acts up the same way.
//Danne


#17

Clearly the modem should NOT have an IP on the internal networks subnet. From a previous post:[b]

Router: 192.168.0.1
Modem: 192.168.0.2
Main puter: 192.168.0.3[/b]

He needs to be here:
WAN (ISP --> Modem -->) LAN (Router --> Computers, Print Servers, whatever)

He may very well have a NIC problem and/or a config problem on the laptop, but as long as the success is being determined by whether or not he has Internet access, then the WAN/LAN config issues needs to be corrected first…


#18

If the laptop has a problem that is not a faulty NIC, try this. It may very well save you from an OS reload…


#19

Shessh…
Why don’t you read again and get it right?
hint Get the router/comp working before fiddling around with anything else.
btw, if you dont have a modem with NAT enabled do NOT connect it to a LAN port on the router. You’ll get a pissed ISP. And to make it work you have to disable the router’s DHCP server.
//Danne


#20

You don’t seem to get it do ya! I have no problem with getting the router/comp issues resolved first. I have a problem with the modem being on the LAN side of the network…

EDIT: Aditionally the modem should not be connected to the lan side of the router in any circumstance. It stays on the wan side. Gee, might even have a labeled input for that, ya think?