Nero's UltraBuffer - how should I tune it?

vbimport

#1

Greetings, friends!

I’ve a problem while recording DVDs on my NEC NG-3500A at 16x. I’m using good media from TDK and this issue is not connected to DVD recorder, but to my Nero 6.6.0.6. My PC is quite good so it shouldn’t have any problems with performance, my IDE channels’ settings are fine too - UDMA 5 for my Seagate Barracuda and UDMA 2 for both CD-RW and DVD-RW. The problem looks like this: when I burn DVDs at 16x, Nero’s “so exclusive” UltraBuffer is jumping all the time - not my DVD recorder’s buffer, but the “topmost big progressbar” which stands for Nero’s own buffer! I’ve tried quitting other applications and setting the highest priority to Nero - some luck, but not the whole solution. I have “Automatic” option set on UltraBuffer’s tab in Nero preferences, and it sets UltraBuffer size to 71 Mb. Maybe the problem could be reduced by changing this value? Actually I don’t understand what do I need this UltraBuffer for when I burn data from my HDD, since it’s just another copy cycle which takes time, but since it couldn’t be disabled, I have to search for optimal value for this option. I’ve 512 Mb RAM (DDR 3200) - what size should I use for UltraBuffer? Maybe 1 Mb? Or all 80 Mb? Do you have any experience on this topic?

Hope to find an answer here :). Thanks in advance for your attention to my trouble!


#2

With auto setting and 1 gig of ram nero sets @ 80mb which I think it recommends as the max value,try setting of 80.


#3

Ultrabuffer is the Nero’s RAM buffer.

Before commencing a write, Nero will fill the software buffer, lets call it 80Mb, the suggested maximum.

As the write starts, the drive will quickly load it’s own buffer (2Mb) from the Nero buffer - and now that is no longer full, Nero will read source files as fast as possible, until full.

Now if your source speed is good, the files not small and scattered, and the writer not contending the same IDE as the source, then the Nero buffer should settle in to a 97-99% flicker, with the drive buffer staying 99% loaded as well.

If the source hits a slower patch, smaller files etc. then the Ultrabuffer will fade down, as it covers the difference between data in and out.

When the Ultrabuffer depletes completely, and the drive buffer, underrun recovery occurs - Nero will refill the buffer completely before restarting.

If it’s jumping, but not hitting zero, then it’s doing it’s job, smoothing out any bumps in throughput - the only reason to use a smaller value, is shortage of usable RAM, since you do not want to cause additional swapping, especially to the drive that is also the data source.


#4

It’s normal to the 2MB drive buffer to go to zero for a split second as the NEC recalibrates the burn. It does this on-the-fly.


#5

+1 it’s called WOPC system.


#6

Thanks for replies! But still I have some questions, if you don’t mind :).

Does this buffer reside in RAM? I thought it is located on the hard drive - that’s why it confused me. Not I realize that I mixed it up with Nero’s cache location. The thing is that if UltraBuffer gets empty, it takes several seconds for it to fill back to 100%, and that is strange since my HDD is quick enough and is on personal IDE cable to provide RAM with data in less time. Maybe I should reduce its size so Nero reads smaller portions of the file while burning?


#7

The adjustable NERO BUFFER is your RAM. The non adjustable buffer (usually 2 or 8MB) is on the optical drive.

If the Ultra Buffers is going to zero, then the hard drive is not keeping up with the burn. Could be caused by slow HD, slow motherboard, bad IDE cable, or CPU load hitting 90 to 100%. Make sure all devices are runnin in DMA mode.


#8

How can I test what component is faulty?


#9

Download HD Tune and post the transfer graph.


#10

Here is it. Is it fine that my HD slows down time by time?



#11

You can test the HD all day long and not fix the problem, which is that it’s not keeping up with your burns. In spite of their ratings and benchmarks, many HD’s cannot keep up with 16x burning. The fix is to lower your burn speed to 12x or 8x, or fix whatever issues the HD is having. Fragmentation is a common cause of this, but burning loads of small files will slow ANY HD to a crawl. Setting Nero to cache files smaller than 64KB usually fixes that.

I’ll bet that your drive is fragmented, and your DVD files are scattered all over the place, which will slow the HD considerably. To fix this, you need a dedicated de-frag utility, as Windows defrag and things like Norton won’t fix it. A quick and dirty solution is this: Set your paging file to 20MB, then reboot. Now run your defrag utility. Next set the paging file to the SAME initial and max sizes at whatever size you need and reboot again. You should now have a considerable larger unfragmented free space on the drive that will allow you to burn DVD files quicker. Another approach would be to create a separate partition to use solely for placing your DVD and cache files there. They will always be unfragmented that way.


#12

I use a separate partition for DVD processing. Your HD is fine, but you also should check the CPU load during the burn. Make sure it is below 80-90%.


#13

Sorry, but you cannot make that assumption based on a benchmark. These programs often use small files for the benchmark. Unless you are testing with 1 GB sized files, it’s pretty meaningless. Obviously it’s not “fine”, as it’s unable to keep up with 16x burning.


#14

Most throughput issues are related to high load on the CPU if the HD transfer graph is stable. If the hard drive is heavily fragmented, there will be dips in the transfer speed.


#15

Well, fragmentation was among the ideas that came to my head when thinking over this problem… I’d just forgotten to set up PerfectDisk after buying a new PC :). Will try to burn - not small files, but whole DVD images - after defragmentation, including offline defrag.

And about the CPU: I had checked that before, it used to be gently loaded.


#16

Although you may not like how this ‘looks’, how are your final burns? Do they play properly? Do you get a good result with NeroCD Speed’s Transfer Rate test?


#17

I haven’t tried transfer rate tests, but the DVDs played fine…


#18

Helo NickMSU, when you begin a new cd/dvd compilation and you are ready for burn it on cd/dvd on the recording properties of the recording box check the box “determine best speed”, this should do the trick :wink: enjoy


#19

I realize you are new and that this is your first post but you are replying to a thread that was last activated February, 2005 for a poster who is also brand-spanking new.