NeroLinux can't access any device

vbimport

#1

Hello, I’m running NeroLinux 64bit 3.1.1.0 on Fedora 8 x86_64.
When I start it, it complains that it cannot access generic SCSI devices (/dev/sg0 -> /dev/sg7, it checks even my card reader), so only ImageRecorder is available.
Now, I understand that changing the permissions of the device files might solve this problem, but I wouldn’t really like to do it, as both k3b and Brasero are working fine, so I don’t see why NeroLinux shouldn’t…

Of course, if I start NeroLinux as root everything works fine.

Should I provide more informations? How?

Thanks,
Dario


#2

Nero Linux has a different device access than k3b or any other tool. With Nero Linux, you must have read and write access to the /dev/sg devices (as explained in the manual).
We are force to use the SCSI generic interface so that we can send any command to the device, including the vendor-specific ones, like for example when changing the booktype of a DVD.

For you case, as you are using Fedora 8, first check that the ‘sg’ module is loaded (or that you have SCSI Generic support enabled if you have compiled your own kernel).
After that, you might want to change the permissions on the /dev/sgXX file corresponding to your devices.


#3

I’m running 32-bit Fedora 8 on my laptop. I was getting access errors from Nero Linux, and then couldn’t use the DVD burner with Nero Linux.

I tried the official solution, to modify the /etc/rc.local file by adding this:

chmod o+r+w /dev/sg*

exit

This did not work. After trying several other things, I found that this worked, and it survives on reboot:

chmod a+r+w /dev/sg*

exit

I don’t know if there are any good reasons not to do it this way.