NeroLINUX 2.1.0.4 available

vbimport

#1

NeroLINUX 2.1.0.4 is now available at this link.

:bow:


#2

Anyone having trouble with this version? I just updated to 2.1.0.4 over top 2.1.0.3 and I got some errors during install and I can’t uninstall it (running Ubuntu Gnome Edgy). First time this has happened.


#3

There is something bad wrong with this release at least for the debian side of the line. I did a restore of my system, deleted 2.1.0.3, then installed 2.1.0.4 via gdebi and received a failed to install message. When I tried to remove 2.1.0.4 thru synaptic I could not. Hopefully Mathf has some info on this.


#4

Interestingly, the change log states:

[PATCH] Fixed syntax errors with the Debian post-installation script.

Perhaps that’s what mucked it up. :frowning:

gibson


#5

Uh oh…I didn’t install the RPM in openSUSE yet…I think I’ll wait for a while until I find out what’s happening with this release…


#6

I used the heck out of this release last night and did not experience any problems. However, I’m not using Debian, mine is Linux From Scratch 6.2.


#7

OK…I’ll give it a try when I get home from work…I’m using openSUSE 10.2 (rpm) and I have never had any problems before…I’ll be bold and play with it…I have a DVD to copy tonight anyway…(legal…it’s not commercial…in case you were wondering…which you weren’t)


#8

We changed slightly our installer to fix a syntax error in the post-istallation script. We also increase portability of it. If this script fails, nero will still run. The only thing is that you will not have any shortcuts to it.

Could you please try to have a look to the error messages you get and post them here ?

PS: I just re-tried to install the package using ‘dpkg’ on a fresh-installed debian 3.1 and Ubuntu 5.10. No problems at all.


#9

I just tried to install this in Ubuntu 6.1. Update no longer works I get the following error
.
In Terminal E: The package nerolinux needs to be reinstalled, but I can’t find an archive for it.

In synaptic I get
E: The package nerolinux needs to be reinstalled, but I can’t find an archive for it.
E: Internal error opening cache (1). Please report.

I’m new to linux and this installer appears to have broken my installation.
Not happy. So much for trusting a major software company

Kev

Edit
Is there a copy of the previous version available anywhere?


#10

Yes, that looks like the error I got. It did say that NeroLinux needed to be reinstalled but when I tried it told me the file was corrupt and would not proceed. I checked the files md5 checksum before installing and it was correct (as posted at the download site).


#11

Just download the package and try to install it in the ‘normal’ way:
dpkg -i nerolinux-2.1.0.4-x86.deb

This IMHO must work. Otherwise you are missing something on your system.


#12

mathf,
Here is the error I got when I ran dpkg -i nerolinux-2.1.0.4-x86.deb from Terminal:

Preparing to replace nerolinux 2.1.0.3-1 (using nerolinux-2.1.0.4-x86.deb) …
/var/lib/dpkg/info/nerolinux.prerm: 31: function: not found
/var/lib/dpkg/info/nerolinux.prerm: 44: RemoveMenuLinks: not found
Unpacking replacement nerolinux …
Setting up nerolinux (2.1.0.4-1) …
/var/lib/dpkg/info/nerolinux.postinst: 70: Syntax error: “(” unexpected
dpkg: error processing nerolinux (–install):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
nerolinux

Hope this helps. :slight_smile: . Now I need to reinstall my system.


#13

Okay! Now I see where the problem is! Some questions/remarks:

  • I know that under Debian, bash is sometimes linked to dash. Is it your case?
    (run update-alternatives --config bash (or sh) to change this)
  • Why do you need to reinstall your system? It is just a postrm/postinst script that fails…

To correct it, go to /var/lib/dpkg/info (as far as I remember…) and edit nerolinux.postrm and nerolinux.postinst. Go to the ‘faulty’ line and remove the keyword ‘function’ kayword. According to bash doc, this should help.

BtW, this afternoon I tried with a brand new installation of Debian 3.1, Ubuntu 6.06 and 5.10. No problems at all…


#14

To report…rpm version installed and worked perfectly…I just copied a DVD to an image file. I also burned a DVD…no problems at all on SUSE…looks like it’s just a debian issue from here…


#15

mathf,
I did a fresh install of Ubuntu Feisty 7.04 (still in development) and when I installed NeroLinux 2.1.0.4 I got the Failed to install error yet it installed. I ran the update-alternatives–config bash and I received there is no alternative for bash. The same for sh. I used gedit to open /var/lib/dpkg/info/nerolinux.postrm and this was what was there:

#!/bin/sh

ESP Package Manager v3.7.0

if [ -x /usr/bin/update-menus ]; then

# echo -n "Updating Debian menus... "
/usr/bin/update-menus
# echo "done!"

fi

I opened nerolinux.postinst and went to line 70:

Creates the desktop file with the parameters above.

Parameter:

- Destination directory for the .desktop file

- audiowrapper command if needed.

function CreateDesktopFile()
{
DESKTOP_PATH=$1/NeroLINUX.desktop
cat /usr/share/nero/desktop/NeroLINUX.template > $DESKTOP_PATH

# Check if we should put audiowrapper...	
if [ $# -eq 2 ]; then 
	echo "Exec=$2 --oss-native /usr/bin/nero" >> $DESKTOP_PATH
else
	echo "Exec=/usr/bin/nero" >> $DESKTOP_PATH
fi

# Finally add the desktop icon... 
echo "Icon=/usr/share/nero/pixmaps/nero.png" >> $DESKTOP_PATH

}

and removed the word “function”…then saved it. I went to synaptic and tried to remove nerolinux 2.1.0.4 but could not (error exit status 2). The same thing happened in Ubuntu Edgy 6.10.

There is something wrong with this release. How do you explain that syntax error?


#16

Is there or are there plans to implement the API kit for the linux version? I’m a developer and would like to have access to the API.


#17

I suggest you try with Ubuntu version 6.10. It simply BREAKS the machine.
This is not simply an error that affects Nero. Oddly nero still works, I CANNOT INSTALL OR UNINSTALL ANYTHING.

Is this Neros idea of a Linux virus??

Kev


#18

I just tried with Ubuntu 6.10 and it breaks. We are currently working hard to build a fixed version and release it ASAP.

For your info, Nero is not a Linux virus… (Just have a look to the script that has been posted above… This is exactly what nerolinux package is doing when it is installed.)
If you do not manage to install or uninstall anything, this could come from the fact that, on Ubuntu 6.10, /bin/sh is a symbolic link to dash… which understands the shell scripts not as bash is doing. THIS is the cause of NeroLINUX’s package problem, and maybe also from yours…


#19

And the fix for my computer is??

Kev


#20

I would definitly say (as root) type in:
dpkg-reconfigure dash

…and after that say ‘No’ when you are asked if ‘dash’ should be installed as the default shell. This should fix lots of problems…