NeroCmd asking for writable media

vbimport

#1

I have the NeroCmd version 5.5.6.2 that came with Nero version 5.5.6.1 OEM, and the NeroAPI.dll that came with it is 5.5.6.1.

I entered the following in a .bat file:

ero
erocmd --write --error_log neroerr.lst --drivename D --create_iso_fs --iso My_CD c:\subdir*.*

With a blank CR-R (48X) in the Ikebana 24-10-40 drive, I ran the .bat file in a command window. The thing seemed to check out the parameters ok (no errors reported), but then asked for a writable CD to be inserted and ejected the one I had loaded. Reloading the CD just gives the same message.

I then fired up Nero itself, brought up the .NRI I had saved from a previous session, and successfully burned the files onto the same CD that NeroCmd wouldn’t use.

What is NeroCmd telling me - what doesn’t it like about a CD that the GUI successfully writes onto?

I have downloaded the newest Nero (5.5.10.42 I think it is), but haven’t yet tried that; I presume it will update the 5.5.6.1 OEM I have, won’t it?). Is the upgrade needed, so I can use arg --media_type media_cdr to be specific about what I have in the drive? That option doesn’t seem to be in the version I have; when I include it, NeroCmd does complain about the invalid switch.

Dick Russell


#2

Well, no one has replied to my post of a week ago, so I’ll reply to my own post, in case someone wants to know how it turned out.

Basically, all I did was to download 5.5.10.42 from Ahead’s site (about 13 meg!), and install the update. This I did last night, and now Nerocmd works properly, whereas the version with Nero 5.5.6.1 wouldn’t. Ahead must have fixed something since 5.5.6.1, but I saw nothing resembling my problem in the update history at the end of the documentation Ahead provides for Nerocmd. Anyway, the thing works just fine now.

By the way, it seems that all I need is NEROCMD.EXE and NEROAPI.DLL, which I copied to another directory (with a much shorter path). I had my batch file run Nerocmd from there. Of course, the thing could be looking in the registry for other things elsewhere; I don’t know.