Nerocbui and visualstudio 2003

vbimport

#1

Problem to compile the examples from the sdk, tried to compile the nerocbui but errors occurs.
using nero 6.1.3.17 registered and visual studio 2003 enterprise
message received:

<<
Command Lines Creating temporary file “d:\dev\NeroSDK-1.05\NeroCBUI\Samples\TestNeroCBUI\Bin\Debug\RSP000008.rsp” with contents
[
/Od /I “…/…/…/NeroAPI/Include” /I “…/…/Include” /D “WIN32” /D “_DEBUG” /D “_WINDOWS” /D “_MBCS” /FD /EHsc /RTC1 /MTd /Yc"stdafx.h" /Fp".\Bin\Debug/TestNeroCBUI.pch" /Fo".\Bin\Debug/" /Fd".\Bin\Debug/" /FR".\Bin\Debug/" /W3 /c /ZI
“.\StdAfx.cpp”
]
Creating command line “cl.exe @“d:\dev\NeroSDK-1.05\NeroCBUI\Samples\TestNeroCBUI\Bin\Debug\RSP000008.rsp” /nologo”
Output Window Compiling…
StdAfx.cpp
d:\dev\NeroSDK-1.05\NeroCBUI\Include\NeroCBUI.h(5674) : error C2143: syntax error : missing ‘;’ before ‘*’
d:\dev\NeroSDK-1.05\NeroCBUI\Include\NeroCBUI.h(5674) : error C2501: ‘LPAFX_OLDPROPSHEETPAGE’ : missing storage-class or type specifiers
d:\dev\NeroSDK-1.05\NeroCBUI\Include\NeroCBUI.h(5705) : error C2061: syntax error : identifier ‘LPAFX_OLDPROPSHEETPAGE’
d:\dev\NeroSDK-1.05\NeroCBUI\Include\NeroCBUI.h(5765) : error C2061: syntax error : identifier ‘LPAFX_OLDPROPSHEETPAGE’
Results Build log was saved at “file://d:\dev\NeroSDK-1.05\NeroCBUI\Samples\TestNeroCBUI\Bin\Debug\BuildLog.htm”
TestNeroCBUI - 4 error(s), 0 warning(s)

>>
What did I miss??


#2

I mean the testnerocbui example provided in the NeroSDK-v1.05, I’m a newbie on this and the documentation still not enought to understand what is missing, can someone help me to understand the errors and if possible confirm that it can be compiled under MS Visual Studio 2003. Maybe settings are not right in the linker/compiler???
Regards,
Martin :confused: