Nero reads a bad sector on burned dvd

Hi!
I REALLY tried to find answer to my problem all over internet, but no luck, so if anyone have a solution it would be greatly appreciated!
So, when i burn dvd data disc in nero (i’ve tried 2 nero versions) it says that burning was completed successfuly, but when it verifies disc keeps reading bad sectors and disc itself won’t work when i try it. i’ve heard about installing new firmware version, but i can’t find the right one.
I’m having LiteOn Atapi iHAS122 and the firmware version is ZLO7 (that is what nero info tool told me).
Please if anyone have any idea it would really mean a lot to me!tnx…

More likely it’s the disks you are using.

^ Agreed. The problem described almost certainly has been caused by using bad or unreliable blank discs.

thanks a lot!
i bought different disc, and they work fine.
but I don’t understand why the other ones are not working. they are verbatim, same as i always use…never mind…tnx anyway!

^ Did you check where the dud verbs were made? Unfortunately, verbs are made in a variety of countries these days and their reliability can vary significantly depending on the country of manufacture.

Then again, you may have just been unlucky and got a bad batch. It happens.