Nero exiting when selecting from menu

vbimport

#1

Have NeroLinux 2.0.0.2-1 installed on Fedora Core 4 x86_64, kernel 2.6.12-1.1398 and Gnome 2.10.
All was working well until a week ago, now Nero exits when I attempt to start an iso burn, disc info, or burn a compilation (CD or DVD). I am able to erase CD-RW and DVD-RW discs with no problem.
I have uninstalled and reinstalled Nero, but it did not correct the problem. Is there a solution?
I do not like having to use K3b.


#2

Have you checked your SELinux log (in /var/log/audit) ?


#3

Yes, I am looking at it now. I will paste a few lines, so you can see what has happened, dose not look good. These lines appear several times, as the log is very long.
Sorry about the smilies, unable to prevent them from appearing without changing text but they are, : colons.

Dave

audit.log:
type=AVC msg=audit(1120326728.655:13719355): avc: denied { execmod } for pid=18541 comm=“ld-linux.so.2” name=libNeroErr.so dev=hda1 ino=17264483 scontext=system_u:system_r:crond_t tcontext=system_u:object_r:lib_t tclass=file
type=AVC_PATH msg=audit(1120326728.655:13719355): path="/usr/lib/libNeroErr.so"
type=SYSCALL msg=audit(1120326728.655:13719355): arch=40000003 syscall=125 success=no exit=-13 a0=f7f10000 a1=cf000 a2=5 a3=ffffc4e0 items=0 pid=18541 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm=“ld-linux.so.2” exe="/lib/ld-2.3.5.so"
type=AVC msg=audit(1120326728.770:13733273): avc: denied { execmod } for pid=18542 comm=“ld-linux.so.2” name=libNewTrf.so dev=hda1 ino=17264485 scontext=system_u:system_r:crond_t tcontext=system_u:object_r:lib_t tclass=file
type=AVC_PATH msg=audit(1120326728.770:13733273): path="/usr/lib/libNewTrf.so"
type=SYSCALL msg=audit(1120326728.770:13733273): arch=40000003 syscall=125 success=no exit=-13 a0=f7ea2000 a1=132000 a2=5 a3=ffffce00 items=0 pid=18542 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm=“ld-linux.so.2” exe="/lib/ld-2.3.5.so"
type=AVC msg=audit(1120326728.864:13745332): avc: denied { execmod } for pid=18543 comm=“ld-linux.so.2” name=libnerocdr.so dev=hda1 ino=17264487 scontext=system_u:system_r:crond_t tcontext=system_u:object_r:lib_t tclass=file
type=AVC_PATH msg=audit(1120326728.864:13745332): path="/usr/lib/libnerocdr.so"
type=SYSCALL msg=audit(1120326728.864:13745332): arch=40000003 syscall=125 success=no exit=-13 a0=f7ec9000 a1=10f000 a2=5 a3=ffffbfd0 items=0 pid=18543 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm=“ld-linux.so.2” exe="/lib/ld-2.3.5.so"


#4

Maybe try this (as root):

setsebool -P allow_execmode=1


#5

Did not work, got this error: Error setting boolean: Invalid boolean

Dave


#6

@mathf

Problem has been solved, in a strange way.
Uninstalled KDE and all libraries, multimedia, K3b, the whole shabang. NeroLinux runs normally now. Had a suspiction K3b was giving me problems. Ever since I installed KDE my system just did not seem right.
I installed KDE and Gnome, to decide which I would keep. I have chosen Gnome, as I do not like the way KDE functions, plus some other factors I will not get into here. I just know since installing KDE, NeroLinux gave me problems. Do not know the specific cause, but it does not matter now.
So to all you KDE advocates, enjoy! :doh:

Dave


#7

Weird :wink: But OK if now it is working then… :stuck_out_tongue: