Nero dont see any recorders

vbimport

#1

I’ve checked permissions and turn-off scsi-emulation. Everything like in manual. But in ‘choose recorder’ window i have only image recorder.
I’m using latest kernel 2.6.11.12 and have LG GCE-8400 and LG GSA-4120.NeroLinux Trial 2.0.0.2.
Any suggestions? Please help :bow:

Regards
emde


#2

Have you the right to read and write to your recorder’s device files ? (something like /dev/hda or else…). Is there no message that pops up when nero starts telling you that you have problem with your device ?


#3

Yes i have all rights in /dev. No messages, no pop ups. But one thing was strange. When I started nero, add files and try to burn cd (no other actions). Then nothing happens. No dialogs, no pop ups. In log only two messages “— recording xx mb … " and " ---- burn process finished ----” or something like that. With image recorder everything is ok (dialog with progressbar,etc.).


#4

CAn you try to launch nero as root ? Maybe there is an hidden perms problems somewhere on your system. If it is running as root, then we can eliminate hardware/kernel problem…


#5

It is launched as root and still the same problem. i’m using kernel 2.6.13, btw.


#6

Which devices are your writers? Can you manually mount cd’s on your system with these devices (does your system recognise them properly?)? Possibly they are on the same cable and set to master or slave?

Does dmesg show them on your system? My device is /dev/hdc, and when I do dmesg | grep hdc I get:

axllent@workstation ~ $ dmesg |grep hdc     
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA
hdc: ASUS DRW-1604P, ATAPI CD/DVD-ROM drive
hdc: ATAPI 40X DVD-ROM DVD-R CD-R/RW drive, 2000kB Cache, UDMA(33)

Does yours produce something close to that?


#7

I don’t have any other problems with my writers. cdrecord, cdrecord.prodvd works fine. I can mount too.

My dmesg:

VP_IDE: VIA vt82c596b (rev 23) IDE UDMA66 controller on pci0000:00:07.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: ST380011A, ATA DISK drive
hdb: WDC WD200EB-00BHF0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: HL-DT-ST GCE-8400B, ATAPI CD/DVD-ROM drive
hdd: HL-DT-ST DVDRAM GSA-4120B, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 1024KiB
hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(66)
hda: cache flushes supported
 hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 >
hdb: max request size: 128KiB
hdb: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(66)
hdb: cache flushes not supported
 hdb: hdb1 hdb2 hdb3 < hdb5 >
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 79X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)

hdparm /dev/hdc ; hdparm /dev/hdd


/dev/hdc:
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)

/dev/hdd:
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)

ls -l /dev/hd[c…d]


brw-rw-rw-    1 glenda   disk      22,   0 Oct 15  2004 /dev/hdc
brw-rw-rw-    1 glenda   disk      22,  64 Oct 15  2004 /dev/hdd

cat /proc/sys/dev/cdrom/info


drive name:		hdd	hdc
drive speed:		79	40
drive # of slots:	1	1
Can close tray:		1	1
Can open tray:		1	1
Can lock tray:		1	1
Can change speed:	1	1
Can select disk:	0	0
Can read multisession:	1	1
Can read MCN:		1	1
Reports media changed:	1	1
Can play audio:		1	1
Can write CD-R:		1	1
Can write CD-RW:	1	1
Can read DVD:		1	0
Can write DVD-R:	1	0
Can write DVD-RAM:	1	0
Can read MRW:		1	1
Can write MRW:		1	1
Can write RAM:		1	1

Regards
emde