Nero cdspeed not detecting drives

[QUOTE=Terramex;2788352]Which motherboard do you have ?
Which ports are the drives connected to ?
What’s the SATA transfer mode setting in BIOS/UEFI ?

If nothing helps you maybe want to have a look at QPxTool - if it works with your drives.[/QUOTE]

If you search the forum you will find other similar posts, so I am not the only one with this problem. I don’t think it is motherboard specific, but in any case I am using a Gigabyte Z97 motherboard. The optical drives are installed on ports 2 and 3 (an SDD and a HDD are installed on ports 0 and 1). Moving the optical drives to different ports does not help. I can not find a SATA transfer mode setting in the bios and I am using AHCI. I believe QPxTool is for Linux and not Windows.

So i take it the SATA mode can’t be set individually for each port.
If it could i would try IDE mode for the optical drives.
Or if your Z97 (which one ?) board has a separate Marvell controller try its ports.

Sorry for asking again: you specifically also tried 4.7.7.16, and not just for installable (newer) version ?

P.S.: there is also a Windows version of QPxTool
https://sourceforge.net/projects/qpxtool/files/qpxtool/0.7.x/0.7.1_002/win32/

[QUOTE=Terramex;2788366]So i take it the SATA mode can’t be set individually for each port.
If it could i would try IDE mode for the optical drives.
Or if your Z97 (which one ?) board has a separate Marvell controller try its ports.

Sorry for asking again: you specifically also tried 4.7.7.16, and not just for installable (newer) version ?

P.S.: there is also a Windows version of QPxTool
https://sourceforge.net/projects/qpxtool/files/qpxtool/0.7.x/0.7.1_002/win32/[/QUOTE]

I don’t see how can I set SATA mode individually for each port. Motherboard is GA-Z97X-Gaming 5 without a separate SATA controller. I tried 4.7.7.16 with same results. I will also try QPxTool. Is this still regularly updated?

I know that this is an old topic, but is anyone currently using Nero and it detects more than one drive? Over the years the only solution I found was to use a separate sata controller or set in bios setup the integrated sata controller from acpi to ide mode. Are there any other solutions?

Depends on the version of CDSpeed and the OS you use.

My experience is Win7 works good, with newer OS mostly not all of my drives are detected

Specifically under Windows 7 64-bit only one is detected from the two (and sometimes more) drives, that are connected to the Intel integrated controller. Previously I thought it was the drive in the first port that was detected, but currently it is the last. All versions that I tried have the same problem.

Strange, know this problem from newer Windows-versions

But I have most ODDs connected via PCI/PCIe-SATA-cards, with all possible chipsets (JMicron, Marvell, Silicon Image) and this one is my favorite:

Currently I can only find SATA cards using ASMedia chipsets.

For maximum compatibility with ATAPI devices, only use SATA controllers based on the Silicon Image Sil3114 chipset. You should also make sure to verify that the card has flashable memory for non-RAID firmware installation.

These can be very inexpensive.

However your issue won’t be resolved by using a different controller, because it is an AHCI driver/OS problem and not a controller problem. There are a few ways to resolve the issue, namely using IDE mode or an AHCI driver that has adequate support for ATAPI devices. My suggestion is to stick with IDE mode, since it works for you.

Could be a problem with newer mainboards because the Sil3114 is a PCI2SATA-bridge.

Eásy to find at Ebay, but mostly NoName-cards from chinese shops. And you can only hope that the card is flashable. Got some years ago a 3112 from such a shop and it wasn´t flashable.

I never saw a card using the Silicon Image Sil3114 chipset. I already have a few cards, but all are using the ASMedia ASM-106 chipset. Sticking to the motherboard Intel controller and using IDE mode works, but I need to run all drives including HDD and SDD in that mode. And I need to reinstall Windows if I switch from AHCI.

I think that brand new motherboards without PCI should be avoided anyway since they are beginning to lose legacy BIOS functions (MBR and certainly IDE-emulation), but if you already have one that has those functions (which we know is the case with the OP) then there exists this adapater to convert PCI-E to PCI.

It’s as simple as requesting photos of the flash chip and checking the datasheet of the IC… some sellers don’t have the stickers on them but one should still verify since they may be using stock photos etc. If I recall correctly the good NOR chips used parallel flash so it is trivial to program the memory with the correct BIOS and solder it on a board that didn’t come with a programmable chip or couldn’t be flashed through DOS for some other reason.

With IDE controllers there was simply no other alternative to the Silicon Image if you absolutely had to use a controller card. Of course none ever had as good support as the native implementation on Intel/AMD chipsets. Heck, I remember even Nvidia nForce used to have issues with certain Pioneer drives back in 2005-2006. Whether it is as critical with SATA is yet undetermined.

I’m a strong proponent of doing it once, and doing it right. That is why I will only recommend chipsets that are through numerous reports confirmed to work and that I have experienced with - thus Silicon Image SATA controllers.

You have seen it now. I just linked you to the ebay page, maybe you can find it for even less from another seller but it’s only $10… the branded ones can ask for 5 times that much! But like I said, this particular issue has nothing to do with the SATA controller used.

As far as the Windows reinstallation is concerned, Xercus kindly provided some info on how to avoid having to do just that in your own topic a few years ago: https://club.myce.com/t/error-scsi-status-4-windows-error-code-121/313946/7

I think you can simply follow the regedit instructions in reverse, to avoid the BSOD when changing from AHCI to IDE mode. Worth a try at least.

I only needed to change the ‘Start’ entry from 0 to 3 in the following registry key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

I then restarted windows and changed SATA mode from AHCI to IDE in BIOS.

Now all drives are detected, but I wonder if there are any side effects.

Nice! Thanks for confirming that it works, I’ll also keep that regkey in mind when switching modes with the MS AHCI driver :iagree:

I can’t think of any serious side effects, I’ve been using nothing but IDE mode on all my PCs. You lose NCQ mode but that only translates to different results in synthetic benchmarks but no real-world difference even on an SSD in my experience.

The SATA controller in Display Manager is listed as Standard Dual Channel PCI IDE Controller and is using the Microsoft drivers (6.1.7601.17514) from 2006. Are there not any newer drivers?

I think even W10 uses 2006-drives from MS.

Your mainboard-manufacturer should offer you drivers from the chipset-manufacturer (Intel, AMD). In my experience the MS-drives are reliable, but not ultra-performant.

If you install Windows it will always use the MS-drivers and never aks you to update it or install the drivers from chipset-manufacturer

@aztekk

Would be hard to avoid PCI-less mainboards if you want an actual chipset. IIRC most mainboard-chipsets use since years bridgechips PCIE -> PCI because no native PCI-busis included. I have no experience how good external adapters work, and AFAIK only LOw-profile-cards are fit in it.

In my experience the LSi-SAS-adapter did good work with all ODDs I´ve tried. It´s not that expensive but you have to crossflash it which not work with every mainboard. I have 3 of these controllers, the 1st was easy to flash. BUt after I tried it in a new mainboard with UEFI I had trouble because only the 1st step (erasing) worked and then the card wasn´t recognized. So I use an older PC with simple BIOS and flasing was easy.

I checked a few times and for SATA they offer RAID AHCI drivers and not IDE.

And according to some articles on the topic AHCI vs IDE, the first should be faster than the second. I am not sure however how noticeable is the difference in performance. By setting SATA mode to IDE, the change is not only for optical, but also SSD and HDD drives.

I guess most ppl don´t notice the difference in speed.

AHCI offers additional feature like NCQ (isn´t that important for a SSD because of the low access times) and Hot Plugin.

TRIM should also work in IDE-Mode

AMD-chipsets, at least til the FM2+ series, offers the possibility to use some ports with AHCI and some with IDE