Nero cdspeed not detecting drives

vbimport

#1

I changed the configuration of the drives in my computer (moved two drives from a controller card to the motherboard controller together with a third drive drive) and nero cdspeed now detects only one drive (I think the drive with the first assigned letter). Windows and all other software detect the drives with no problems. I tried uninstalling cdspeed and installing it again and still it does not detect the drives. Any ideas how to fix this?


#2

Having again the same problem after installing (I think) the Intel Rapid Storage Technology drivers. Only one of two drives is detected by nero cdspeed, but windows detects both drives. I tried cleaning the registry to force nero detect the drive but without luck. Last time I had the problem I installed windows again. Any suggestions?


#3

hello

i have the same problem under w10
even changing drive letter wont help
it shows only my blu ray burner (which is not supportet) not my 2 other dvd drives

with w7 it worked


#4

Nero DiscSpeed seems to get confused by the port numbers the drives use. Opti Drive Control that uses drive letters instead of ports seems to be working fine.


#5

@kyrcy & otto0815
If you’re using NeroCDSpeed 4.7.7.16 you can copy the latest Starburn wnaspi32.dll to the NeroCDSpeed exe path and try again.

WnASPI32.zip (287 KB)


#6

[QUOTE=Terramex;2781205]@kyrcy & otto0815
If you’re using NeroCDSpeed 4.7.7.16 you can copy the latest Starburn wnaspi32.dll to the NeroCDSpeed exe path and try again.[/QUOTE]
Already tried this with no luck. I am using Windows 7 64-bit if it matters.


#7

Anyone found a solution to this problem?


#8

Which motherboard do you have ?
Which ports are the drives connected to ?
What’s the SATA transfer mode setting in BIOS/UEFI ?

If nothing helps you maybe want to have a look at QPxTool - if it works with your drives.


#9

[QUOTE=Terramex;2788352]Which motherboard do you have ?
Which ports are the drives connected to ?
What’s the SATA transfer mode setting in BIOS/UEFI ?

If nothing helps you maybe want to have a look at QPxTool - if it works with your drives.[/QUOTE]

If you search the forum you will find other similar posts, so I am not the only one with this problem. I don’t think it is motherboard specific, but in any case I am using a Gigabyte Z97 motherboard. The optical drives are installed on ports 2 and 3 (an SDD and a HDD are installed on ports 0 and 1). Moving the optical drives to different ports does not help. I can not find a SATA transfer mode setting in the bios and I am using AHCI. I believe QPxTool is for Linux and not Windows.


#10

So i take it the SATA mode can’t be set individually for each port.
If it could i would try IDE mode for the optical drives.
Or if your Z97 (which one ?) board has a separate Marvell controller try its ports.

Sorry for asking again: you specifically also tried 4.7.7.16, and not just for installable (newer) version ?

P.S.: there is also a Windows version of QPxTool
https://sourceforge.net/projects/qpxtool/files/qpxtool/0.7.x/0.7.1_002/win32/


#11

[QUOTE=Terramex;2788366]So i take it the SATA mode can’t be set individually for each port.
If it could i would try IDE mode for the optical drives.
Or if your Z97 (which one ?) board has a separate Marvell controller try its ports.

Sorry for asking again: you specifically also tried 4.7.7.16, and not just for installable (newer) version ?

P.S.: there is also a Windows version of QPxTool
https://sourceforge.net/projects/qpxtool/files/qpxtool/0.7.x/0.7.1_002/win32/[/QUOTE]

I don’t see how can I set SATA mode individually for each port. Motherboard is GA-Z97X-Gaming 5 without a separate SATA controller. I tried 4.7.7.16 with same results. I will also try QPxTool. Is this still regularly updated?