Nero CD Speed Help?

How do I change the drive from CLV to CAV?

THe reason is because the drive(Liteon 52246S) reads/burns very slow. I’ll try to get the CDSpeed charts up, need to find a place to host them. The average read is 21x, and yes this is an original stamped cd, and no cdr.
I’ll try updating firmware again if I find time, but I really doubt it’ll make much difference.
The drive is on MultiWord DMA Mode 2. I have reinstalled chipset drivers many times. Also, it is on the Primary IDE channel as device 0, master. There is no slave.
My System is Athlon 1.2 Ghz w/ 512ram, wd 80gb hd, and ibm 30gb hd.

===============================

General Information

Operating System Windows XP Professional
Drive LITE-ON LTR-52246S
Firmware Version 6S08
Serial Number
Disc Data CD
Capacity 72:32.53

Transfer Rate

Start 21.18x
End 15.78x
Average 20.27x
Type CLV

Seek Times

Random 80 ms
1/3 96 ms
Full 144 ms

CPU Usage

1X 5 %
2X 10 %
4X 20 %
8X 41 %

Interface

Burst Rate 3070 KB/sec

Spin Up/Down Times

Spin Up Time 0.07 sec
Spin Down Time 3.87 sec

Load/Eject Times

Load Time 1.40 sec
Eject Time 1.52 sec
Recognition Time 5.85 sec

Time Elapsed Action
[16:28:25] Starting Transfer Rate Test
[16:31:59] 3:34 Speed:21 X CLV (20.27 X average)
[16:31:59] Starting Seek Times Test
[16:32:07] Random seek: 80 ms
[16:32:17] 1/3 seek: 96 ms
[16:32:31] 0:32 Full seek: 144 ms
[16:32:31] Starting CPU Usage Test
[16:32:46] CPU usage at 1X: 5 %
[16:33:01] CPU usage at 2X: 10 %
[16:33:16] CPU usage at 4X: 20 %
[16:33:32] 1:01 CPU usage at 8X: 41 %
[16:33:32] Starting Burst Rate Test
[16:33:37] 0:05 Interface burst rate: 3 MB/sec (3070 KB/sec)
[16:33:37] Starting Spin-Up/Down Test
[16:33:41] Spin-up time: 0.07 seconds
[16:33:55] 0:18 Spin-down time: 3.87 seconds
[16:33:55] Starting Load/Eject Test
[16:33:57] Eject time: 1.52 seconds
[16:33:58] Load time: 1.40 seconds
[16:34:04] 0:09 Recognition time: 5.85 seconds

The CPU load of your system is quite high (I see it reaches above 40%). Can you perhaps put your drive in UDMA33 mode? And are you sure that your harddrives are in some UDMA mode as well?

Originally posted by SkYLiNe
How do I change the drive from CLV to CAV?

The drive is on MultiWord DMA Mode 2.
Here’s 2 suggestions :

  1. Goto in WinXP > right-click My Computer > Properities > Hardware >Device Manager >
    IDE ATA-ATAPI controllers > right-click Primery IDE Channel > Uninstall
    Re-Boot

Enabling DMA in the registry

HKEY_LOCAL_MACHINE > SYSTEM > CURRENTCONTROLSET > CONTROL > CLASS >
{4D36E96A-E325-11CE-BFC1-08002BE10318}

There may be a few subdirectories called 0000, 0001, 0002, 0003

In each of them (it does not matter how many you have as long as it is in all of them)
add a new DWORD value.

Call it EnableUDMA66

Give it a decimal value of 1 to enable DMA. Reboot to see changes.

Note that you may already have this registry entry, depending on certain chipset drivers.
Whatever the case, it’s worth checking to see that it’s there.

Originally posted by Dee-ehn
The CPU load of your system is quite high (I see it reaches above 40%). Can you perhaps put your drive in UDMA33 mode? And are you sure that your harddrives are in some UDMA mode as well?

My mobo has a builtin highpoint ata100 controller, there are 2 special slots for that on the mobo. I don’t have to set anything for the devices I plug in that, so I’m assuming the HD’s are already set to ata100.

I have even tried plugging the cdrw to those slots, and it works, BUT it makes it even worst(slower). I think it might be a problem with my mobo (KT7-RAID) w/ VIA 686 chipset.

I’ll try those suggestions you guys made and report back.

In modifying the registry, I right click when I’m in that folder, then new->DWORD Value right? I enter in that name for it, then I right click on it to modify the entry. But after typing in value and checking the DECIMAL box under base, I press OK, I go to modify again, and it goes back to Hexadecimal?? WIll that matter?

Originally posted by SkYLiNe
WIll that matter?
No. it doesn’t matter. The value must be 1 < that’s what counts.

Yup tried that earlier today… didin’t work… still stuck on MultiWord DMA Mode 2…

I’ve tried everything! Reinstalled 4-in-1 mobo chipset drivers again, IDE Bus Mastering Driver… blah…

Originally posted by SkYLiNe
[B]

My mobo has a builtin highpoint ata100 controller, there are 2 special slots for that on the mobo. I don’t have to set anything for the devices I plug in that, so I’m assuming the HD’s are already set to ata100.

I have even tried plugging the cdrw to those slots, and it works, BUT it makes it even worst(slower). I think it might be a problem with my mobo (KT7-RAID) w/ VIA 686 chipset.

I’ll try those suggestions you guys made and report back. [/B]

It amazes me that CDRW drives even work on this controller, as most RAID controllers do not support ATAPI, and thus optical IDE drives.

Your mainboard is equiped with the KT133 chipset from VIA. This should be no problem at all. I used that chipset over 2 years without a single problem. My LiteOn always was in UDMA33 mode.

Does your BIOS report the drive to be UDMA33 mode? Or does it tell you it is in DMA mode 2?

To make sure it is not a hardware problem, could you perhaps try to make a clean install of e.g. Windows XP on another partition, just for testing?

Normally, the method given by BoSkin should work, but apparently we’re dealing with something strange here. Did you perhaps install the wrong IDE drivers once?

Yeah I know its not really supposed to work with the highpoint ata/100 RAID controller, but it did. Anyway its plugged into one of the 2 other slots controlled by the mobo chipset itself.

I formatted just a couple weeks ago, so I have doubts it’ll be the OS. But I can try installing winxp on another partition as you suggested.

IDE drivers shoudl be right because it is in a package(VIA 4-in-1’s)…

OMG… I don’t know what happened… I just burned a cd right now expecting it to take like 5 mins, but it poped out in 2. I looked in Device Manager and found the drive is now set to Ultra DMA Mode 2!!! I don’t know what it is that made it suddenly work, but oh well, as long as it does! Thx ALL for the help!