Nero BackItUp 4 restore problems

I recently did a clean install on my system, and one of the backup methods I used was Nero BackItUp 4. I previously had an older version of BackItUp installed, but wanted to try the newer version since I had problems with errors with disc closing with the older version, which would often crash a backup job in the middle.

I’ve tried to restore portions of the backup, and have run in to some serious and very confusing problems. I’m hoping someone here can help me out. (Fortunately, this was not the only backup I used, though it was the most comprehensive–all my personal data and pictures were also backed up through two other methods, so I’m not in a panic, though I would certainly like to get it fixed.)

I backed up using the one-file-at-a-time option, with no compression, since I wanted the set to be backward compatible with my older BIU and so that I could drag and drop single files out of the set.

Now, finally to the problem: BIU 4 claims that it has restored the files correctly, and I can see the individual files/topmost folders in explorer. However, explorer shows them as zero bytes, and attempting to access them results in a locked file or no permissions error. When I attempt to correct this with Unlocker, it reports that they do not have any locking handles on them.

This happens both with large and small restores. With large ones, which I have tried twice, I observed an interesting thing: The progress bar counts up to the size that is reported for the backup, which agrees with the size of the folders on the backup drive. The size of the folders being restored also agrees with what BIU is reporting at any moment. However, when the progress bar gets full, there are still files being restored. At this point, a curious thing happens–the size reported by explorer for the restored files starts shrinking, eventually reaching zero at the time the restore completes. Also, during the restore, I am able to at least somewhat navigate through the files being restored.

After a restore job, BIU reports that the .nbi is corrupted (until after a reboot).

I’ve tried large restores twice, with the same effect. I’ve reformatted the disc volume as well, but the issue still persists.

Since the files are backed up individually, I can drag and drop them off, so I should be able to live with it. The biggest annoyance is that the filenames are 8.3. Barring correction of the nbi, is there any way to read the original paths and names from it so that I can at least manually rename files after dragging them?

Any help is appreciated!

Thanks–

Darth Binkly