Nero 8: Fails to realloc DVD files

I am trying to use Nero 8 to author DVD video. The burn application I wrote works well with Nero 6 and 7. But when I try to run the same application on a Nero 8 system I run in to a NEROAPI_BURN_FAILED error.

I am not sure if I need to rewrite my application with any other flags or callback routines. I have also tried updating to the latest version of Nero API 7.0.5.6.
The error message does not make any sense when I dump Nero error log because I do have the VIDEO_TS directory and the I can burn the same directory from another machine with Nero 7.

I would appreciate any thoughts or help ! Thanks.

When I dump Nero error log I get the following:


Windows XP 5.1
IA32
WinAspi: -

NT-SPTI used
Nero API version: 8.1.1.0
Using interface version: 7.0.5.6
Installed in: C:\Program Files\Nero\Nero8\Nero Burning Rom
Installed in: C:\Program Files\Nero\Nero8\Nero Burning Rom
Internal Version: 8, 1, 1, 0

Recorder: <PLEXTOR DVDR PX-716A> Version: 1.56 - HA 1 TA 1 - 8.1.1.0
Adapter driver: <IDE> HA 1
Drive buffer : 8192kB
Bus Type : default

=== Scsi-Device-Map ===
CdRomPeripheral : HL-DT-ST DVD-ROM GDR8164B atapi Port 0 ID 0 DMA: On
CdRomPeripheral : PLEXTOR DVDR PX-716A atapi Port 0 ID 1 DMA: On
DiskPeripheral : ST3500630AS atapi Port 1 ID 0 DMA: On
DiskPeripheral : ST3500630AS atapi Port 1 ID 1 DMA: On
DiskPeripheral : ST3500630AS atapi Port 2 ID 0 DMA: On
DiskPeripheral : ST3500641AS atapi Port 2 ID 1 DMA: On
DiskPeripheral : Seagate ST3500641AS 3.AA mv61xx Port 3 ID 0 DMA: Off
OtherPeripheral : Marvell RAID Console 1.00 mv61xx Port 3 ID 20 DMA: Off

=== CDRom-Device-Map ===
HL-DT-ST DVD-ROM GDR8164B D: CdRom0
PLEXTOR DVDR PX-716A I: CdRom1

AutoRun : 1
Excluded drive IDs:
WriteBufferSize: 83886080 (0) Byte
BUFE : 0
Physical memory : 2045MB (2094596kB)
Free physical memory: 1557MB (1594612kB)
Memory in use : 23 %
Uncached PFiles: 0x0
Use Inquiry : 1
Global Bus Type: default (0)
Check supported media : Disabled (0)

23.10.2007
NeroAPI
12:05:48 AM #1 DVDREALLOC 4 File DVDVideoCompilation.cpp, Line 1181
VIDEO_TS directory not found

12:05:48 AM #2 Phase 115 File APIProgress.cpp, Line 285
DVD-Video files reallocation failed

12:05:48 AM #3 Text 0 File NeroAPIBurnFS.cpp, Line 218
Failed to realloc DVD video files

Existing drivers:

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)

I had the same thing and got it working when I added the constant NERO_BURN_OPTION_USE_JOLIET to the NeroIsoTrack.BurnOptions.

I am doing the following.
IsoTrack.SetISO(TRUE);
IsoTrack.SetUDF(TRUE);
IsoTrack.SetJoliet(TRUE);
IsoTrack.SetReallocDVDVideoFiles(TRUE);

Did you mean this ?

If those are your burnoptions then that should do it.

What language do you use?

C++

I am wondering why Nero would think the VIDEO_TS directory is missing. First, the directory is present, and second, I can see that I am adding to the ISO track as an entry.

I know. In earlier versions of Nero the same code without the extra parameter just works. Must be a bug or a bug fix.

Any other thoughts on this issue? Is anyone running in to same issue with using Nero 8 on C++?
Thanks

You need to fix the .ifo files, they hold all necessary info about the content.