Nero 7

I am having problems burning a multisession disk with nero 7 ultra.
I want to use a disk to save pictures, then go back at a later time and add to the same disk.
I start up nero burning rom 7 and select multisession disk, then I select the photos I want then I burn them. No problem. When I go back to continue multisession disk, the program tells me that I can’t write to this kind of disk. It asks for a dvd rw, even though that is what is in the drive.
I’ve tried this a couple of different times with the same result. After I burn something to a new cd or dvd, the program seems to turn a rewritable disk into a read only.
I would really appreciate some help. I’m pretty sure it is something I am failing to do but I am not sure what it is.
Thanks.

I’m a newbie too and have my own probs with Nero, but go to nero vision by "make your own DVD " then when you get to "vision4 " click “back” and chose " make DVD " and then "editable DVD " I’ve never tried it but the manual says it’s for what your tring to do.

Unselect FINALIZE disc when you want to use Multisession mode.