Nero 7 Premium Reloaded now supports Windows Vista

I recieved a newsletter from Nero AG yesterday titled Nero is Ready for Windows Vista, anyway for anyone that’s interested you can read more on the link below.

The Link provide information on VISTA capability of Nero Premium but not Download site. Look like the new Nero Premium like Ultra Edition is not rady yet to be install in VISTA environment.

If you take a look at the bottom of the page in the link you will see three options, BUY NOW, UPDATE & UPGRADE, clicking on update takes you to the download page, this suggests to me that Nero 7 Premium Reloaded is compatible and ready for Vista.

Also take a look at the release notes for Nero 7.5.7.0, the release notes say that Nero 7.5.7.0 is Vista ready.

^^ But v7.5.7.0 is NOT vista compatible! It still give me COM Surrogate errors!

However, remember there are two version of VISTA 32 bit and 64 you can install the Nero over VISTA 32 bit that is not really VISTA at its best but for real VISTA (64 bit) Nero compatibility upgrade will be available some time at banging of the 2007 as you can read on the news section of CD Freaks.

:iagree: Roxio 9 seems the way to go with Vista x86. I can’t even get CDSpeed, nor ImgBurn, to burn smoothly on my nForce3. x64 was better (but there Roxio won’t install).

That’s not a Nero issue, it’s a codec issue. Installing the ffdshow codec solved the problem for me. Have a look at this thread for more inoformation.

I have been using 7.5.7.0 on two Vista builds with no issues at all. Vanilla burning, Recode and Vision all work flawlessly, as does CD/DVD Speed.

I have ffdshow installed! The problem comes ONLY when i install Nero, and it goes as soon as i un-install Nero!

Do you have any other codec packs involved? Many of these bundles have older codecs installed that can cause problems with Vista. Have you tried installing ffdshow AFTER you install Nero?

Did you happen to have Nero Lite installed before 7.5.7.0? I had some issues on one of my rigs until I uninstalled Lite, used the Nero Clean Tool to remove any remaining junk, and installed the full version from scratch.

Yes, i DID install ffdshow after i installed nero. I did install nero lite once… Lemme try the clean tool and report back. Thanks for taking the pains!

Nope… Tried the clean tool also, but still i get the COM surrogate error. I give up!

Just a couple of suggestions on the COM Surrogate problem.
The Nero DivX codec needs to be registered with your system and this is done by starting Nero ShowTime in administrator mode. (Right click on the ShowTime icon and select ‘Run as administrator’) It only needs to be done like this once.
If you down load the latest DivX bundle v6.4 and install it after you have installed Nero.
None of the above might work but worth a try
HB

Yeah… Always i did a custom install and installed ONLY burning rom. Now i did a typical install and everything is fine! Thanks for all the help everyone!

To save from getting error [ Com Surrogate has stopped working]


step1- Enter In organize menu in Documents folder

step2- Click on “Folder and Search” option

step3- click on “View” option

step4- selct option “Always icons,never thumbnails”

step5- click on “apply”

             problem will be solved

sahil
if it works pls reply me.