Nero 7.9.6.0 Won't Play Any DVD's

Hello;

I’m kind’a new at all this, but I’m going insane with frustration.
I’ll start with what I have . . .
Compaq Presario - AMD Athlon XP 2000+
1.67Ghz and 512MB Ram, CD burner, Internal 40GigHD & External WD 250GigHD (both hardrives have plenty of room).

I recently bought and installed an internal SONY DVD-RW Model DVR-830-A.
This DVD burner came with some version of Nero 7.

Initially everything worked great. I could play any DVD I threw at it, both copywrited movies and newly burned personal DVD’s (no infringement DVD’s ever made or played). Both WMP (ver 11) and Nero 7 worked great.
Then when my freebee Nero 7 was about to run out, I opted to spend almost $70.00CDN on Nero 7.9.6.0. Did the download and install, and now I can’t play a darn thing! :a
When I try to play a DVD with either my WMP or the new Nero (it plays with it’s SHowTime3) I get the message;
“Nero ShowTime has encountered a problem and needs to close. We are sorry for the inconvenience.”. With a send error report under that.
Tried . . .

  • reinstall , no help
  • remove the old Nero (even used Nero’s clean sweep or whatever it’s called), then do reinstall - no help
  • tried some codec things like loading K-Lite Codec Pack, no help (but WMP at least now plays the sound, but still no picture).
  • tried redownloading Nero 7.9.6.0 2 more times (incase of correpted download) - no help

I can see that it knows there’s a DVD there, but I went through all the same DVD’s that played before and none of them work anymore.
What’s up!?!?!?!

I still need help but here’s an update . . .
I downloaded and ran Eusing Regisrty Cleaner and now WMP works great :slight_smile: , BUT all my Nero problems still exist :frowning: .
Help!

Seems like everyone has given up on respondng to my problem, but that’s OK.
After spending 5+ (kind’a lost track already) steady hours trying to make this P.O.S. Nero junk work, I’m requesting my money back.
:frowning: