Need to replace corrupted Sony DRU-530A firmware

vbimport

#1

Hi. I have a Sony DRU-530A. Somehow the firmware on my device became corrupted – out of the blue the device ID string changed to gibberish and the device is no longer recognized. I tried using a Sony firmware update tool hoping that I could re-flash it, but the tool refuses to work because the corrupted device ID doesn’t match the ID it expects.

I looked all over the place for a DRU-530A firmware replacement I could maybe use with Mktflash, but was unable to find one. So I’m asking here if anyone has a firmware for this device, or knows where one can be found?


#2

The firmware is not corrupted. There is surely a problem with the cable connecting the drive to the computer. Try replacing the cable.


#3

I hadn’t thought about that before. Nice suggestion, alas I replaced the cable (tried two others), disconnected the slave, tried swapping IDE sockets on the board, tried the off board PCI-IDE card (a Promise 20268) and also tried the drive in another machine entirely… and still the same problem.


#4

Can u r be Detected by windows?