NEED SERIOUS Lite-ON CDRW DRIVE HELP!

I have a LiteON 16x burn 10x reburn and 40x read, LTR-16102b CDRW DRIVE…the drive can for some reason the drive CANNOT be used meaning windows xp sees the drive but says always “the device is not ready” for some reason? :frowning:
I recently reflashed it with latest firmware of OS0K using MTKflash from DOS, that completed sucessfully…
Still having same problem…
This problem instantly started to occur when i installed a new dvd-rom drive into my computer…
I think i have the jumper cables messed up and this is not a hardware problem… anyone help?
UPDATE: ok (info gathered from nero info tool…)
My primary IDE channel on my comp is 2 hard drives…
My CDRW+dvdrom drives are on da second ide channel…
LiteON DVD-ROM drive is in Second IDE channel master
LiteON LTR-16102b CDRW drive is in Second IDE channel slave
Should i put cdrw drive first and dvdrom drive second? currently only dvdrom drive works… HELP i really need my cdrw working…
and the nero info tool also shows DMA off for liteon cdrw, how can i enable that also? PLEASE HELP! THX! :frowning:

well that does sound odd… did you clean install windows xp when u installed it? if not, i would highly recommend u do this.
Since this will give u ALOT less problems in tha long run.

also could it be a motherboard issue?

Also about your enableing DMA for your lighton drive u can switch it to dma in device manager… (i think u can put that drive to udma,cause i can put my 24102b drive like that)

well good luck :slight_smile:

Originally posted by wzoo1

how can i enable that also? PLEASE HELP! THX!

  1. Enabling DMA in XP ( Secondary IDE channel in your case ) :

Control Panel -> System -> Hardware tab -> Device Manager ->
IDE ATA/ATAPI controlers -> Secondary IDE Channel -> right click ->
Properties -> Advanced Settings tab -> Transfer Mode ( in Device 0 / Device 1 ) -> DMA is available

  1. The best is to set the machines on the separate IDE channels

Try redecteting the drives

"Originally posted in the M$ Newsgroups

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro
l\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits are likely 0001, 0002. Under those keys you will find MasterIdDataChecksum, SlaveIdDataChecksum. Delete the value corresponding to your drive. It will make the OS to redetect the device DMA capabilities after reboot."

Try removing/deleting the IDE Driver (Primary or Secondary) on which the burner is located from Device Manager & reboot.

XP will re-install fresh IDE drivers & redetect the devices. Hope this solves your problem.

Yes, this one is a simple and very effective trick -
it once helped me even better than the previous “regedit” one.