Need help with sony dvd rw dw-d22a

vbimport

#1

I just built a new system with a Sony Dvd Rw Dw-d22a drive. It reads music cds and dvd-rs but will not read any commercial dvd. On the sony website I cant find a drive for it either. It is a dual layer burner, I dont know if its new and they dont have drivers out or if its old and they dont have drivers. Although in its properties the drive says 7/01/2001. I need help! i want to be able to watch purchased dvds and back up dvds.


#2

I am having problems reading commerical dvd’s with my one week old sony dvd rw dw-d22a drive. It reads audio disks and will burn audio also. It also will read dvd-r’s, just no real commercial dvds. It is a new model and I cant find any drivers or updates on the sony website. Any help would be so helpful, thank you very much.


#3

Do you actually have any DVD decoding software (like WinDVD, PowerDVD, etc) that will allow you to view DVD video?


#4

What do you mean by ‘read’? Read as data or ‘play’? If you have a 2nd drive; DVD burner or DVD-rom, repeat what you did. See if the same result you got from the new drive. :rolleyes:


#5

@ md343
Welcome:) Please do not cross- or double-post :cop: (mods-merge?)You did not answer Two Degrees’ question before you started a new thread in the same forum. Please post your answers to this thread only.

You can help us help you by posting a Nero InfoTool system scan. make sure all 8 boxes are checked and save as a .txt file. Attach using the ‘manage attachments’ button in the ‘go advanced’ reply window. Also, does the drive recognize the pressed(commercial store-bought or rental) dvd and just not play it, or does the drive not even recognize the disc? Please be more specific in your problem descriptions.


#6

Hey sorry about my double posting. I did because no one was responding back to my first thread I had started and I was frustrated. My drive won’t reconize any dvd’s besides dvd-r disks. It will just try and load a commercial dvd forever and nothing will pop up in my computer under my D drive. I have attached my nero info tool data. Thank you for your help everyone.


#7

Two things you could try: Remove the NTI software, roll back to default microsoft ide driver. One other point, you should also update to nero 6.6.0.3.


#8

@ md343
ala42 makes excellent suggestions. If those don’t resolve your problem, I have read that virtual cd software can cause conflicts. You could try to uninstall it just to test the theory, then you can try to reinstall the latest version of it…6.0? Report back if any of these work!


#9

I have unistalled the Nti software and virtual cd. My drive still wont read dvd’s, it just sits there trying to load forever and the drive says busy in all programs and my computer. I am curently downloading all of the six nero updates to see if that will help anything. But I am having a problem finding the Mircosoft ide driver, I have searched on google with no luck and cant find anything on mircosoft.com Any help would be awesome, I cant wait till I get these issues figured out.


#10

Nothing needed to download, the default driver is built in. Use the driver rollback button in the device manager IDE controller properties/driver tab.


#11

it says no driver files have been backed dup for this device. Then gives me a option to go into the troubleshooter. I never had the mircosoft ide drivers installed on here, just had the nvidia one that came with my motherboard.


#12

Then select delete/uninstall driver and reboot. The microsoft drivers get installed automatically on the restart.


#13

I deleted the nvida driver and rebooted. when windows came to the desktop it found new hardware, “sony dvd rw dw-d22a” and a cd-rom drive. Shouldnt it just be my sony drive? Also it it seemed to install the nvidia drivers again automatically once it found the new hardware. This is strange


#14

You’ll need to uninstall the nVidia nForce drivers from Add/Remove Programs.


#15

Ok the nvidia nforce drivers are gone. Now i just have the default windows drivers for all my ide and ata. Yet still no reading of commercial dvds! My drive will read retail audio and cd-r and dvd-r, also burn cd-r. What do you think I should do now? I have the nvidia dvd decoder installed also, but none of the dvd player apps i have tried will open and my drive will not detect the dvd.


#16

Attach the nero infotool output of the current config. Which DVD player did you try ?


#17

I used the nero dvd player to try and open up a dvd movie. Also windows media player 10


#18

Bump, I need help stilll


#19

You still have NTI installed and have added the packet writing software INCD, which might cause additional problems.
Have you tried a Data DVD ?
Can you see the title and directory of a DVD-video ?
Does KProbe detect the DVD ?


#20

I have a data dvd burned, it read and played the game fine when i put it into the drive. I cannot see the title or directory of the dvd video when I insert it into the dvd drive. I have unistalled the nti software, so it should not be on my computer anymore, the same with incd. In the other thread " sonydwd22a problem" i post my nero infotool from earlier today. what do you think I should do now? would flashing to a non oem drive work? how do i do this? if not flashing, what do you think should be done?