Need help with new DW1620

vbimport

#1

Just got two new BenQ DW1620 burners from Compgeeks.com. I wanted to make sure I had the latest firmware, so I downloaded it from BenQ and tried to run it. But it says “Drive not support” Same problem with both drives.

The drive name shows as “ATAPI DVD DD 2X16X4X16G7Z9”

This was in an NForce based system and I read a lot of posts on here about NForce IDE drivers causing problems, so I moved the drive to an Intel 865 platform and I still see the exact same problem.

The label on the drive say’s “BenQ Corporation”, so it should be a true BenQ drive, not a clone, right? Model number is DW1620-201.

Is the drive supposed to show up as “ATAPI DVD DD 2X16X4X16G7Z9”?
Why doesn’t the BenQ firmware update software recognize this drive?


#2

Do a little searching in this forum. You will find that you have the OEM version, which, by default, will NOT directly flash to the retail firmware that you probably downloaded. The simple solution is to get a .cvt version of the retail firmware and use winflash utility instead of the .exe that you downloaded. Search a little and you will find MANY threads.


#3

Check here: the reason it’s not showing up as a DVD / burner is because you need to up the firmware…

Follow the instructions for converting OEM drive to retail B*** firmware and you should be set to go.

http://club.cdfreaks.com/showthread.php?t=123232


#4

Thank you!
I did search around the forum, but didn’t know exactly what to look for.


#5

Ok, read my post and use the links for downloading the files.
If things are still not clear, don’t hasitate to ask for explanation.
read this here


#6

Got the firmware fixed. Now the drive shows up as BenQ DW1620 and it’s working great. Burns my Sony 8X DVD-R disks at 16X. :wink:


#7

Glad everythings is working fine, please post a scan in the media thread. I sure like to see a scan of a 16x speed burn.


#8

Sorry if this is a daft question but i’m having problems with my benq 1620 in an external usb2 enclosure, how do i know if ive got the drive set to “master”?

And how do i change this setting if i need to?


#9

I think it’s cool that I notice more and more people when they buy BenQ DVD Burners they buy 2 at a shot.

@bigdanc123 - the only way to really know is most likely opening up the enclosure and checking the jumper on the back of the drive. In the enclosure it’s setup like a regular IDE drive. What kind of problems are you having with the BenQ? What kind of enclosure is it? Have you tried flashing to 47L9 using WinDWFlash and the appropriate .cvt flasher? :slight_smile: This corrects a lot of problems for BenQ’s in external enclosures.


#10

@Braxas
Yes, its the same as a normal ide.
It’s a ME350U2 enclosure.
It will write DVD’s OK, and play DVD’s OK, but if i open “My Computer” and try to open the drive with a blank DVD in, it says “Unable to open. Incorrect function”.
It doesn’t seem to write any faster than my internal writer (I only have 4x DVD-R discs tho, does this restrict it?)
I’m new to this so i apologise for my ignorance, but would appreciate any help.
Thanks.