Need help with Liteon SOHW-1633S Burner

Hello,

I recently crossflashed my Liteon SOHW-1633S BSOY with 1653 CSOT. Everything worked at first. Then suddenly one day my drive stopped reading Pressed CD/DVD. It works fine with DVD-R/RW.

I tested its reading and writing capabilities with different media. It worked great on all except CDRW. It could not read or burn CDRW.

So, I flashed the drive back to 1633 BSOY. It still gives me same problems described above. :sad:

I searched for possible solutions on various forums (and of course google). I could not even find similar problem. Please help me with this.

Hello, from months ago:

“Today, I decided updating a LiteOn 1633S-BPSD (HP PC) drive, to a 1653S-CS0T patched firmware. Unfortunately the new firmware caused a noise while reading an unscathed CD at high speeds, upon investigating the realization was, the issue only happened exceeding 40x plus speeds. I decided to revert and concluded, firmware CS0T read CDs at a rate of 48x max, while the old BPSD only 40x, thus doing the twist at that rate does not make that noise which may break your hips!”

Not the same issues, but definetly issues with the CS0T firmware on a 1633S drive.

Hope it helps!

most older liteon OEMs firmwares had the cd speed limited to 40x (e.g. Sony writers), but i don’t think this is causing the problem above.

@deltasquare4
do you have packet writing software, like Nero InCD, installed?
have you tried booting from a CDRW?
have you tried removing the drive from device manager and rebooting your computer?

Thanks for your reply, guys.

@chok0

  1. I do not have any packet writing software installed.

  2. I didn’t tried booting from CDRW, but I rebooted my system after It failed to read a CDRW. Drive LED just keeps blinking and nothing happens.

  3. Yes, I also installed the drive in my other system. But, it didn’t work in both the cases.

Additionally, I do not have any concern if it won’t read CDRW. I just don’t deal with them that much. Only thing bothers me is it rejects pressed/factory made CDs and DVDs. It is such a pain.

sorry… i meant you should try boothing from a pressed bootable disc, liek a windows installation disc.
if it boots, then you know there’s a problem with your OS and not the drive.

but if the drives behaves the same in different pcs, then there’s not much hope to get it working. at this point you could try a downgrade.

Hello,

I tried booting from pressed CD. Amazingly it worked. Now, sometimes it recognizes a pressed CD but it never recognized But, I could not boot from pressed DVD.

I already downgraded to 1633 BSOY firmware before posting here as I specified above. I also tried resetting CMOS of the drive. But, it didn’t work so, I restored it from backup I took before resetting.