Need help with LG GSA-H10l LL11

I just got a new h10l and i seemed to have ruined it with some chink firmware i got off of google. it still burns good and all but when i pop in a blank media disk it doesnt have what would youlike to do? burn etc or it wont populate the blank media. I burned a disc in nero and it worked… I was wondering if i could reveert to ll01 so it would hopefully work again. and it keeps saying its a cd rom drive and switches to dvd ram , dvd /cd rw etc… please help!

  1. there’s no LL01, i guess you mean LL10.
    you can’t go back to LL10 since there’s no version of it available for download from LG, nor can it be extracted from a drive.
    my recommendation is to use TDB’s patched LL11 firmware which you can find here:
    http://tdb.rpc1.org/#GSAH10L

  2. about Windows saying it’s a CD-ROM drive or a DVD-RAM drive, that’s normal, ignore it.

You are a huge life saver, praise you . Happy Holidays/ Christmas which every you preffer. thanks man!

Please refrain from using derogatory terms. :Z

welcome.

Yes, that’s a Windows problem too. :smiley:

I have (2) H10L burners in my newly built computer. I cannot get the computer to recognize either of the drives. The burners appear to be installed correctly. I have (3) newly built computers with (2) of the same H10L burners in them…I have the same problem with all (3) computers. Your advices would be most appreciated!

are the drives recognized by Windows at all? do they appear in the Device Manager?
are they recognized by the BIOS?

have you checked and made sure the jumpers are set correctly?
tried changing the IDE cable? placing the drive alone on the IDE cable?