Need help with DW1620 firmware update

vbimport

#1

I flashed my Philips DVD8631 to a BenQ DW1620 B7T9 using WinDWFlash and B7T9.cvt from

http://dvdpro.club.st/firmware/BENQ_FW.htm

The flash was successful - the drive now shows as a BenQ in Windows Device Manager. However, whenever I try to run an official BenQ firmware update exe, I get a “No Device Found!” error popup. I am trying to switch to the B7P9 firmware to compare performance, but now I’m afraid I won’t be able to update the firmware at all.

Please help!!!


#2

Have you tried the same method, using a CVT file for B7P9? Should be easy to find at the Dangerous brothers website.


#3

If you want to go back in firmware, why don’t you use B7P9.cvt form the same site.
That should work. Have you already made some burns with your B7T9 firmware and how were the results.


#4

Xterminator,

Also getting an error when trying to use WinDWFlash and B7P9.cvt from the same site - “There is no disk in the drive. Please insert a disk in drive D:”.

cor808,

I haven’t done any in-depth performance testing yet…just did some basic functional tests like playing and ripping to make sure the drive was still working, which thankfully it is :slight_smile: Supposedly flashing the drive should allow it to be updated with official BenQ firmware, but no luck here…


#5

81rooster, not sure what you are trying to do but that error does not seem to be related to flashing your drive. At what step of the updating process does it occur exactly?


#6

An even more fascinating question is: Can the misbehaving older Philips be flashed with Philips 1640 firmware in order to access the latest 3.2 Philips 1640 firmware?
There’s something else that should work.


#7

I don’t really get what is wrong with your drive. If there is anything wrong.
The error “there no disk in the drive. Please insert a disk in drive D” is certainly not a error of WinDWFlash as far as I can imagine!! :confused:
You try to flash the drive without burning a dvd to see what the result is?
I would first download the original B7T9 firmware from here. Do burn a disk to see what how quality of the burning is.

I’ve had a bad B7T9.cvt flash myself and solved the problem with the original *.exe file. If your a newbie don’t go flash the drive without knowing the consequences. Don’t go flashing the drive just for fun.
If you haven’t made a burning it’s hard to see if there was a mis flash.
Let us know how things went.


#8

So I tried an official BenQ exe again today and it worked…how bizarre!! I don’t know what the deal was with the errors, but it appears to be working now, so I’m satisfied.

Burned to a 4x Ritek +R at 8x in under 9min. I don’t have any higher speed media or -R’s at the moment, so those tests will have to wait. I’ll be doing some more message board reading to see what the best media is.

Thanks for everyone’s help!

FYI…
I am a newbie, but I did plenty of research and message board reading before attempting the flash. I wasn’t pleased with the performance of the drive as a Philips, so there was good reason for the flash – it was definitely not done just for fun. I understood the potential consequences, was willing to take the risk, and followed instructions to a cue…just ended up encountering some strange behavior.


#9

Congrats on the flashing success.
Now stick around, post some scans, and discuss your results and experiences with your BenQ drive :smiley:


#10

Maybe it wa a bad flash with a *.cvt firmware.
I’m happy for you things workes out fine now. and your drive is in good shape.
:wink:


#11

For others that may have this problem, I recently installed a 1640 and tried to flash the firmware. I got a warning message saying to turn off programs etc. and after pressing “ok” a tiny little screen pops up saying “no device found”. Then a window with “my computer” and no drives. Try going to device manager, right click on your dvd drive and select properties. Now go to “region” and set it. Try flashing again. :wink:


#12

Hi :slight_smile:
Must be something else going on.
See this thread. Posts #'s 5 & 6.