Need help with 3520a

vbimport

#1

I just got it and when I try to flash it with the LD3520 Beta 2 it just locks up my system. I have tried the io-data firmware as well with the necflash tool also.
It will scan the drive fine and I can dump my current firmware but when I try to flash it it just locks up.

I’m on XP pro with SP2. Any suggestions you have will be greatly appreciated. As this current 1.04 firmware really sucks

I’d like to rip and burn at speeds that this drive is actually capable of. 26 mins to rip and encode a movie with my dual cpu system is wayyyy unacceptable as my 4x can do it in 14 mins or less.

And my ridata +r 16x discs only being recognized as 4x burns me arse too.

thanks in advance for any help you can offer


#2

while i am by no means an expert on the subject…you clould try flashing it in dos, also if you have the drive in an external enclosure there are known flashing issues (do a fourm search if this is the case).


#3

tried it in dos with necflash but it gives an error trying to open the bin file. I have tried 2 different bins and get the same results.

any better flash utilites I could use?


#4

Finally got it to flash I had to uninstall my ide drivers and use the -v command
necflash -flash -v (myfile) e:

worked but my 16X media which is DVD+R:RITEK-R04-001
I sure hope that a future firmware update includes this media.