NEED HELP PLEASE!..Having issues with the Pioneer 109-Recordnow max 4.5

OK, so I just received a new Dell CPU setup and installed my Pioneer 109 drive into it thinking that it would be a smooth sail. I was wrong!

For some reason the 109 takes FOREVER to burn. 4.3 gigs in 73 minutes with the Ritek 4x media dvd-r. I have never before had this experience. Especially with the 106 drives. A ps2 game usually only took 20-30 minutes tops.

So I followed the thread:
and updated my pioneer firmware to version 1.57 (did this before I read the thread)…then copied the required files into the appropriate folder and got recordnow max to recognize the drive, but it burns at 4.3gigs at 73 minutes or 3.1 gig at 55 minutes…

I also had recoednow max 4.5 and easy cd creator 6 together.
I removed recordnow max 4.5 and downloaded recordnow 6 and it had me remove easy cd creator. But with easy cd creator 6 gone and recordnow 6 installed it is still taking 60 minutes for 4 gigs…

What am I doing wrong here?
Is there a way to flash the drive back to original and start over?

NEED Help PLease!

did you use a 80 wire ide cable? its a must for your burner as its ata66 and 40 wire ide cable will make it slow , also its best to connect a burner with another optical drive or standalone if you connected it along with a hard drive that aint good

look at this dma guide
if you connected the drive along with a hard drive then connect it with another optical drive or standalone , and if you used a 40 wire ide cable change it to 80

I have the 109 connected with the dvd rom that it came with…
And am using the standard ide cable that it came with…whatever that may be…

Will changing the cable actually make the difference in recording?
of course along with faster media?

flat 80 wires ide cable :
flat 40 wires ide cable :
basicly you can tell by the connector colors and all rounded ide cables are 80 wires

yeah,40 wire ide cable limits to udma2/ata33 (33mb/s) and your pioneer is udma4/ata66 (66mb/s) therfore it will run much slower on a 40 wire ide cable for best performance its best to use 80 wires ide cable

have you looked at the dma guide? whats in “current transfer mode”?

edit: what cpu do you have? you need at least P3 800MHZ for this drive

I can t really tell…

this is the cable that I have:

might as well just get a different cable anyway right?

Hi :slight_smile:
If you’re using a ide cable that came with the 109 then it should be 80 wire
If that’s the case you want to check that the computer recognises the 109 as UDMA 4 Anything else UDMA 2 or PIO mode will result in slow / poor performance
The cable in the Yahoo link diagram would seem to indicate 40 wire price 80

this is the dell cable that came with the cpu…which is probably the 40 wire

How do I check to see if the cpu recognizes the udma 4?

its 100% 40 wire ide cable you should get a 80wire one , anyway that price is way too high for an ide cable it usallt costs between 4-7$

as he alredy mentioned he isnt using the cable that comes with 109
he bought the cable in seperate,anyway 109 is mostly sold as oem and that doesnt come with an ide cable


cpu isnt related to udma modes and it doesnt have any cables you mean pc,i was saying you need to have at least PENTIUM3 800MHZ as its pioneer-109 system requirement

thanks fellas for the help…

will post when I get back from the store…

you welcome :slight_smile:
just dont get back from it with another 40 wire ide cable
have a look in the ide cable pictures see links above basicly as alredy said you can tell by the connector colors

Hi :slight_smile:
On reading the above I took it that he was using the standard ide cable that it came with ( meaning with the 109 )
The Yahoo link I took to be for illustrative purpose’s
At no point was oem or retail mentioned
I realise now on further reading he meant cable that came with computer & already in use ( DVD Rom) :doh:

Your DVR-109 should have come with an 80 conductor cable. It has 3 different color connectors on it. The Blue connector would go to the motherboard connector and the other two to each drive. Once installed, verify in both BIOS and System control panel that you’re running that port with UDMA rather than PIO.

so I went a purchased a 80 pin ide cable and it is still reading at 64 minutes for a 3.9 gig file…

What is going on here?
Should I flash the unit back to original 1.17?..rather than the updated 1.57 now?..
If so how do I do this?

Hi :slight_smile:
It sounds like you need to enable UDMA

Go desktop > My Computer > right click > Properties > Hardware Tab > Device Manager >IDE ATA/ATAPI Controllers > Primary / Secondary IDE Channel > Advanced Settings > Transfer Mode > Select DMA if available

It says that the select dma if available is selected…

I mean I am only using the 4x ritek media, But when I was using a different slower cpu with the 106 burner, it still burned 4 gig files @ 25 minutes…

Dont know what else to do here…

take a screenshot of “advanced settings” window in the ide channel and upload it to and well see

that cable @ yahoo is 40 Wire not 80

thats correct and i have alredy mentioned it and he bought another one

how can I save the screenshot as a jpeg to upload?