Need Help on how to open the enclosure, so I can take the drive out

vbimport

#1

:slight_smile: Hello, I’m new here and I have a problem with my I/O Magic Gigabank 320GB Drive. It cant be recongnized by my PC, and I’ve tried about everything to get it to work besides putting it in the PC and seeing what happens, so I’m gonna try that. The only problem is, I cant see how to open the enclosure so I can take the drive out. There’s a metal template on the back which I cant get off, also there’s those 2 black parts and the front and the back which wont come off either. Can someone help me? Because I really need the data off of it.

Thanks,

:cop:

(NICE SITE!)


#2

Welcome to the forum. I had one of those, but gave it to my daughter (away at college). But these are some general hints: rub any stickers on the bottom to feel for hidden screw holes. If the feet aren’t glued on, they might hide screws too. Gently tug at or pry any trim pieces especially on the sides of the case. Sometimes you need to squeeze the sides to open a case, especially if there are no screws. Hope this helps.


#3

Cool! Am I just going to be using my hands to pry it then?


#4

probably.


#5

I tried opening it with my hands but I just cant seem to do it. Would using like plyers or something work?
<input id=“gwProxy” type=“hidden”><!–Session data–><input onclick=“jsCall();” id=“jsProxy” type=“hidden”>