Need help : flashed wrong firmware in Optiarc AD-7560S

vbimport

#1

Hi,
My laptop(Sony vaio VGN-CS17G) has Optiarc AD-7560S.
I was using Sony supplied firmware(SS05).
I rarely use the DVD drive and very rarely use it to write CDs.
Ubuntu 10.04 was released and i was eager to test it.
I downloaded the iso and tried to burn it to a CD.
I used Infra Recorder to burn the CD but the process failed (i dont remember the error message)
I tried with another CD from the same manufacturer(moserbaer) and it failed again.
I went to the store near by and bought two Sony CDs and tried to burn using default program that comes with Windows 7.
It too failed.

I googled the problem and, it lead to this post.
Even though the last comment clearly says that it does not work on vaio laptops, i was so stupid (and intoxicated) at that time and flashed it with the wrong firmware(SD05).

After flashing, the drive is detected in operating system(Windows 7).
It shows up in every dvd-burner related software(K-Probe, infra recorder).
I noticed that there is a change in the device name. Before flash it was Optiarc DVD-RW AD-7560S and after the device shows up as Optiarc AD-7560S ATA Device.
(I do not know if my drive is ATA or SATA, how can i find it?)

After flashing, the drive wont detect/read any media, If insert any type of media the disc spins and after a few seconds it gives no disk message and ejects tray.

Then I tried to flash my original firmware but the program does not work any more(it simply exits).
Fortunately the SD05 firmware came with a DOS program(QSIFlash.exe) to flash QSI devices.
I tried to look for alternative firmwares(.bin files) but i could not find any and this page confirmed that custom firmwares are not available.
With some guess work i extracted the .bin file
Here are the steps i followed

  1. Used universal extractor to extract the executable file
  2. The program extracts the contents of the executable into some files.
  3. The .data file has firmware in it.
  4. I opened the dell supplied SD05.bin file in editor(Notepad++) and observed the data pattern
  5. It is 1703936 bytes, I opened the .data file, found a matching pattern and extracted 1703936 bytes from it(wrote a program)
  6. I then saved the extracted firmware to a a USB disk(has FreeDOS in it).
  7. I booted my laptop into FreeDOS and ran the QSIFlash.exe program with the SS05.bin file as argument.
  8. The program says it successfully flashed the firmware.

I do not have much doubts about my process of extracting the .bin files from the sony supplied .exe files.
I tested it well and the QSIFlash.exe program wont accept just any .bin file.

Now i rebooted my machine and booted into windows 7, The firmware version is shown as SS05 but the drive name remains the same(Optiarc AD-7560S ATA Device) and behaves the same.

Now i request you to give your kind advice on further steps to perform to make my drive read DVDs again.
Any kind of help is much appreciated.