Need DOS driver for Hitachi optical drive (GSA-U20N) - Boot disk problems

vbimport

#1

A user I know has a Dell Latitude E6400 computer with an optical drive marked Model No.: GSA-U20N
LGE0DMGSA-U22F(B)
(which I believe is a Hitachi?).

It is absolutely essential that I get this working this way. I need to use a utility to de-crypt the hard drive before I can go fixing windows or recovering data.

I need a DOS driver for a win98 style boot disk. I tried editing config.sys for each of the big 5 (CD1.sys, CD2.sys, CD3.sys, CD4.sys, CD5.sys) but none of them allow me to boot. Does it require some newer driver and if so where can I get it?

Thanks for any help on this.


#2

Hi,

normally, the DOS drivers that are on a Win98 or WinME bootdisk should work.
Make sure, the Sata controllers are set to “IDE” (Bios setting). Also, you can’t access NTFS formatted HDDs from a DOS environment without 3rd party software.

Instead of a DOS based bootdisk, I would try something WinPE based (BartPE or a Vista install disc). A Linux Live disc like Knoppix would be another option.

Michael


#3

Sata is in IDE. I’m not trying to access the hard drive yet.

I’m trying to get the ramdisc or whatever the boot disc creates/does to be able to read from the optical drive. I need to run a little program called recover.exe from it to unencrypt the hard drive. Problem is it comes up as “Device driver not found ‘cd001’” yada yada.

I dont think this program will run in a windows environment, or at least they havent provided one to us. I’ll start messing with a Ultimate boot disc build but the installer was crashing because our corpoate network is blocking it.


#4

Got it to work. Not 100% sure how.

I decided F*** it and replaced the mscdex with cdromsys.exe - a program that has all 5 cd.sys files inside it, at first I thought it was just a self extracting archive but now I think it can detect which driver the optical uses and sets that to be used.

Weird though that I made the first 5 discs using the cd.sys files extracted from cdromsys.exe and none of them worked… yet this one did.