Need clarification on making a SecuROM backup play-disc using RMPS emulation

vbimport

#1

Hi all,

I have been using these forums to feverishly research making backups the last few days, and have run into a point that i don’t understand.

I am trying to back up Tomb Raider: Legend. Preferably, i want to be able to play it from the hard drive for the sake of convenience and to see if it improve performance e.g. when loading levels (but i would be happy with a copy of the DVD itself - at least then i won’t get paranoid about scratches on the DVD). TR:L uses a DVD play disc and SecuROM 7.

I have Alcohol 120%, full version, on this computer, and Daemon Tools Lite on the computer i use for games (that computer isnt connected to the net, otherwise i’d just use my Alcohol license on that one (or buy Daemon Tools Pro)).

From tutorials here, i have gleaned that you need something called RMPS emulation enabled.

But i am confused. Is RMPS emulation something that you do with a virtual drive, or is it something that you do with a physical drive?

I found one tutorial that said you need to copy the DVD with RMPS emulation, and then burn the copy to a disk, which makes me think that RMPS emulation is something you only do with a physical drive.

But then in other places, people seem to say that it is actually impossible to make SecuROM back-up discs unless they are CDs (rather than DVDs). My disc, copied then burnt in Alcohol using RMPS, will not run. Do i need to somehow mount this RMPS disc in a virtual drive to make it work?


#2

I don’t know much on backingup tomb raider backups. But I do know from my uses of CloneCD that it worked on making backups of NWN2 and expansions and those disc installed and worked as original disc and ran fine without any problems. And I think that those disc had secuROM feature on them but doing with CloneCD I was able to make working backup that played just like they were originals disc. I don’t use emulators as didn’t have much luck with them rather at least with the disc I can reinstall them when needed again if I have to. But that is how I do it. Make working working backup copy and put original in safe place so as to not damage them incase the backup becomes to scratched to be of use anymore then I copy the original again and use those backup. But I think alot of load time has to do with what kinda CPU/GPU/RAM you have in your system that another part you should look into when playing high resolution games. All the drive does is load at certain point but I think that is only when you first start that it reads the security portion of the disc to insure you have a legit version after that all the game should be run from the HDD.


#3

[QUOTE=dissembly;2544126]
But i am confused. Is RMPS emulation something that you do with a virtual drive, or is it something that you do with a physical drive?
[/QUOTE]RMPS emulation is only needed when burning a physical copy.
Further you have to tick RMPS emulation in Alcohol’s (or DAEMON Tools’) options before loading that burned copy.

Whether you’re mounting an image to a virtual drive a burning a RMPS copy with Alcohol 120%:
your drive needs to be capable of performing a DPM (Data Position Measurement).
If it isn’t, you can try this mds file instead of yours: http://space.wismar-wacken.com/thomas/DPM/Tomb%20Raider%20Legend/


#4

Hmmm maybe my drive just can’t do DPM - the drive on my non-internet-connected gaming computer is a few years old now.

Thank-you forthe link to the .mds file. I used that .mds to burn a new disc with my copied .mdf, but it didn’t have an effect unfortunately.

The same thing happened as before: the cursor changes into an image of a spinning DVD, then after doing that for a bit the obnoxious SecuROM message appears, saying “Please insert the original instead of a copy (1000)”.


#5

You have ticked the RMPS Emulation option in Options/Emulation ?
If yes, try to temporarily deactivate your security software as it might alter the emulation timing.
If that doesn’t help please use the official SecuROM Removal Tool and try again after a reboot.

Have you also tried the image in a virtual drive ?
If you still have it, would you please attach your original MDS file ?


#6

Hopefully the original mds file is attached. Thank-you for taking a look! I have labelled it as "txt"to allow it to upload, but it is an “mds” file.

I have “RMPS emulation” ticked in DaemonToolsLite, and I have done it without security software running.

I hadnt tried the SecuROM removal tool, but i gave it a try just then (and restarted, as well), but it has the same effect as before.


(I should mention, my .mdf/.mds files are called “TRL”, but when i burnt using the .mds file you gave me, I changed the name of my .mdf file so that the names would be the same, just in case that caused any problem.)

TRL.txt (38.4 KB)


#7

Using your MDS the game starts fine on my system.

If you’re running Vista/7 try whether it helps to deactivate Windows Defender.
Try to produce as few load as possible.

Some people reported that issue was caused by overclocking.

Personally i’ve experienced that a Mini image raises success chances when having such an issue.

  • Download WinHex trial version
  • Open your mdf image file
  • Edit -> Define Block… (Beginning: 0, End: 87FF (hex) or 34815 (dez))
  • Edit -> Copy Block -> Into new file; save as *.mdf
  • use your original mds file with that Mini mdf

When mounting that Mini Image you won’t see a Volume label in Explorer,
just ignore that and launch via desktop shortcut.

P.S.: burning that Mini Image won’t produce a working backup


#8

I tried your suggestion, but this time the mds/mdf files don’t seem to run at all.

I get the message “Mounting image”, but then nothing happens.

I’m running Windows XP, i’m not sure if it has an equivalent to Windows Defender, but my startup settings are fairly minimal (one of the first things I do with windows nowadays is go msconfig -> startup -> uncheck everything that looks unnecessary!).

It sounds really strange that it works fine on your system - is it normal for things like this to happen? I feel like I’m so close, yet so far away. Last time I made a copy of my disc, i noticed a minor scratch on my disc. Doesn’t seem to affect performance, but it raised my blood pressure a bit… I so hate SecuROM!


#9

[QUOTE=dissembly;2545112]I get the message “Mounting image”, but then nothing happens.
[/QUOTE]Using a Mini Image you won’t get an Autorun splash screen, cause the Autorun routine isn’t present anymore in that image. Just mount the mini and launch the game via start menu or desktop shortcut.

[QUOTE=dissembly;2545112]I’m running Windows XP, i’m not sure if it has an equivalent to Windows Defender
[/QUOTE]No, it hasn’t.

[QUOTE=dissembly;2545112]It sounds really strange that it works fine on your system - is it normal for things like this to happen?[/QUOTE]It’s an expection still happening too often; most common reasons:

  • bad Data Position Measurement
  • high CPU load
  • Security software disturbing the check / messing up the emulation timing
  • overclocking
  • (very) fragmented HDD
  • SecuROM f****** around

Regarding that last point: people reported they solved that problem by uninstalling other apps/games protected by SecuROM.
I don’t know if you have any, but as you already tried the SecuROM Removal Tool that [I]shouldn’t[/I] be the culprit - but who knows :confused:

EDIT: Have you already patched the game to v1.1 or 1.2 ?
Sometimes SecuROM fixes/alleviates the check with patches.