Need a little help with an image of KOTOR

vbimport

#1

I’m using CloneCD version 4.2 I believe (I know there are normally 4 numbers but I can’t get at the other 4 right now). I have an original copy of KOTOR and installed it on a new laptop (Inspiron 9100 if anyone cares to know). I decided that carrying around the stupid play cd was gonna anger me so I wanted to make an image and just mount it using CloneCD so I can play the game. I used default settings and CloneCD happily churned out an image. I then updated KOTOR to 1.02 (I think that’s the latest patch). When I went to run the image the game spat out something about Securom and emulation and once again asked for the original CD to be placed in the drive.

If I uninstalled, then reinstalled and tried to use the Image file mounted to the virtual drive, would this fool the game into thinking that the virtual drive is the original install drive and kill this error message (wow thats a mind blowing sentence right there)? Is there something a bit more fancy I need to try? I’m not interested in copying the CD onto other media, just running the Image file instead of the play disk.

Any help would be greatly appreciated.
OC


#2

With CloneCD by itself, it does not read the appropriate SecuROM copy protection information needed. There is a tool called TwinPeaks that we use to insert Twin Sectors into the image to ‘fool’ the guard module into thinking it’s an original. But this is only used for burning strait onto a disc. It can’t be emulated on a Virtual Drive.

To emulate this the best option would be to grab yourself a copy of Alcohol 120%. With that make an image with the SecuROM *New [4.x/5.x] Datatype and read the DPM info at 1x. With that, you can mount the image onto Alcohol or Daemon Tool’s virtual drive.

But blacklisting may have got to it before Alcohol or Daemon Tools could update.

Good Luck!:slight_smile:


#3

Thanks for the quick reply Cyber :bow: .

By blacklisted, do you mean that KOTOR somehow detects that a certain brand of virtual drive software is being used? I noticed on one of the updates for, I think it was CloneCD, that it said it had removed some blacklistings (or something to that effect). I haven’t tried with a newer version but I think I may purchase a newer version and see if KOTOR recognizes the updated virtual drive software.

Any other hints would be greatly appreciated.
OC


#4

Yep, with Blacklisting the protection searches the machine for any virtual drives/emulation options. If it finds any, it will produce an error (Depending on the protection the errors can vary). If you have bought the software already you should be able to upgrade for free. If not get the trial version and see if you like it.:slight_smile:

Good Luck!