Need a little help plz!

vbimport

#1

hi, ive no hardware issues as such, just that i need to access my cdrw from a startup disk for installation/troubleshooting purposes and i havent been able to work it out yet!

OS:WinXP PRO
Sys:AsusP4C800-E Deluxe, 2.6ghz, 512mb DDR
CDRW nfo:

D:\BCD\bin>cdrecord dev=1,0,0 -checkdrive
Cdrecord 1.11a40 (i686-pc-cygwin) Copyright © 1995-2002 Jörg Schilling
scsidev: ‘1,0,0’
scsibus: 1 target: 0 lun: 0
Using libscg version ‘schily-0.7’
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'LITE-ON ’
Identifikation : 'LTR-52327S ’
Revision : ‘QS0B’
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE FORCESPEED
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R

ive tried adding the usual mscdex flags to autoexec.bat config.sys etc using the default ‘cdrom.sys’ file found on XP doesnt seem to be any other, also tried some scsi drivers provided by adaptec, neither which have worked… just returned with illegal options or device driver not found etc neway dont know why its being reported as a scsi drive since its plugged into an ide/atapi interface?

ps. ide configured as Enhanced mode in BIOS which shifts hdd to 3rd primary master and cdrw to 5th primary master in ide device list (if that makes any difference regards detection i dunno)

would like to hear any suggestions, cheers


#2

got it working in the end. for those of you interested…

i just copied 2 files over from a maxblast3 floppy (actcd.sys,nwcdex.exe) and added these flags to autoexec.bat & config.sys respectively

<autoexec.bat>
NWCDEX.EXE /d:generic /l:x (where X is ur last drive)
<config.sys>
DEVICE=ACTCD.SYS /D:generic
LASTDRIVE=Z

also had to turn off IDE Enhanced mode otherwise CDRW was not detected

fyi: ide/atapi uses wnaspi to enumerate a scsi device