Need 52246 owners who back up there games

vbimport

#1

Just installed lite on 52246 into a Belkin ext usb 2 case. Very disappointed to start making a back up of desert combat( safedisk 2.7), using safedisk 2 tab, as i have two young boys, and finding after 22 mins of grinding through the normal disc errors, I had only imaged 1.92 MB of 658mb. Now my plextor 4012a ( 1 sheep burner) imaged complete disc in 2m 55secs. My question is the lite on performing correctly and is very slow on skipping read errors, is it faulty? Or am I missing something.
It’s difficult to see how the drive is faulty as I wrote a 600mb file in just over 3 mins on a RW disc. Even the QSL drive in my laptop images this disc quicker. As a point of interest is the quality of the imaged game linked to the read quality and correct EFM writing, or could I use the plextor to copy very quickly and write a true 1.1 copy with the two sheep lite on. Many thanks for any advice.


#2

The LiteON has been known to take longer than other drives skipping errors, but not that long.

But yes you can read with the Plextor and write with the LiteON and still get a perfect copy.


#3

hi Chriso thanks for the reply. Usefull info to know.

i was suggested a work around using alcohol 120%, thanks to phoenix on 120% forum, i used the FastDump feature, and produced the image in under 3 mins. thanks again for help.


#4

Or use BlindWrite 4.4.

SafeDisc is no problem anymore.

Whe should focus on SecuROM (combined with Fade), StarForce 3 (and 1 and 2 of course) and Tagès.

I don’t have any CD’s protected with Ring Protech, but is this copyable??


#5

yes, I have the original cd of Ironstorm and the backup I made (using ddump/fireburner) to reduce reading times work well in my dvdrom.
Greetings.


#6

Just installed lite on 52246 into a Belkin ext usb 2 case.

I’m not clear on this, did you install an internal atapi 52246 into an external usb 2 case yourself? If this is the case, perhaps there is a setting that is wrong and the drive appears to be a usb 1.1 to your computer, because, from what I was told when I was interested in a usb external drive (until my internal drive crapped out and I replaced it in kind, my computer’s usb ports are ver. 1.1), usb 1.1 tops out at 4x, despite the drive being capable of much faster reading/writing.

But then, perhaps I am misunderstanding your statement. If you bought it pre-installed in a usb case, it should run at max speed, if you have a usb 2.0 port on your 'puter.

Just a thought.


#7

hi Saruman. Yes the drive was installed as you describe. It is connected as USB 2, write speed is fine, high 40x on a test file. The problem is the drive is very slow skipping block errors on reading a sd2 protected disc. My Plextor, 1sheep drive, skipped through in under 3 mins on a 658mb file. My LiteON after 22 mins had not even reached 1%. Using the fast dump feature on alcohol 120%, my program of choice, imaged file under 3 mins and produced a perfect copy just over 2mins, so problem solved. I am still suprised after reading so many posts from LiteON owners as to how good these drives are for producing personal back ups, that nobody mentioned the poor read performance. I was hoping a 52246 owner imaging a sd2.7 disc could report there experience.


#8

I’m CHRISI, and also a 52246S owner:
I read about the slow reading of a safedisc image and had a very similar problem after the installation. I made a Firmware Update and afterwards it was much faster at skipping read errors. A SafeDisc Image now only needs about 10 min or less for reading process.
TRY A FIRMWARE UPDATE!!! If you haven’t done so yet. I always use my LTR drive to read safedisc titles, as my other drive is some AOPEN crap…
cheers
chrisi