Nec3550@4551 running pio only

I did the update of my dvd burner nec 3550 with the firmware 1.z2 (using necbfl.exe and binflash 1.24) so for what i know it should work as a nec 4551
but if i try to enable DMA when i put everykind of dvds xp look like crashed until i eject the dvd
please help
thanx

IDE primary channel aw-g170a sony (master) and NEC 4551 (slave)
os xp sp2

You’ve tried deleting that IDE channel (Primary) in Device Manager, rebooting, and letting Windows re-detect it?

yes but don’t work
it run only pio mode

If i can remember correctly you have to flash the boot menu first. I think the necbfl.exe was what i used.

I had the 4550 and enabled the lableflash to make it a 4551. I am sure its probably the same method.

As stated you need to flash the boot and select 4551 in the options. There should have been 3. Then you need to use binflash to dump the exsisting firmware. Then flash with the 4551 firmware again. Reeboot.

It should now work correctly. Make sure your using an 40/80 IDE cable for be compatibility available.

Sorry but i sold my 4551 a while ago, as i would have tried it and see if i could get it to work.

Many NEC experts here. Please hold tight and someone will help. :bigsmile: