NEC3520A Firmware update failed

vbimport

#1

I decided to update the firmware on my NEC3520A from 1.04 to 3.04. I got the updated firmware from the NEC site so it is an official firmware update. I used a Windows flash utility that came with the updated firmware and it confirmed that I had an NEC3520A with firmware 1.04 and asked me if I wanted to flash it to 3.04. I chose yes and it started to flash but then a message came up saying there was an error so I cancelled the update. I noticed the light on the drive flashing so I left it for a while but it continued to flash so I rebooted the computer.

Now the drive does not work properly but the firmware is still recognised as 1.04. I tried flashing it back to the original 1.04 firmware but it failed to do it from Windows. The only thing I can think of now is trying it from dos. My drive was not the boxed retail version coming in a plastic bag with a software CD only. Could it be that a cheaper non-boxed bare bones drive requires a different firmware?

The drive could still be saveable as the firmware is recognised and it still partially works. According to the NEC site I got the firmware from I flashed it at my own risk so I have no come back with NEC even though I used their official firmware. I suppose I could still return it claiming it just stopped working properly but I want to see if I can fix it myself first. I have updated firmware on other drives before and never had a problem and have no idea why it failed this time. Any advice before I attempt to restore the original firmware from dos would be appreciated.


#2

I tried to flash it from Windows again using different utilities and it did the same thing each time-the update stopped after a few seconds and the light on the drive flashes continuously. Thankfully it is still showing as Firmware 1.04 but the firmware is partially damaged. I tried writing the original firmware over the damaged one with a utility I got from The Dangerous Brothers but it looks as though it would not do it because it sees it as already there. Can a firmware be made to write the same firmware over itself? Unless someone has a suggestion I may try installing the drive in another computer and seeing if it will update or perhaps I should give up before I damage the drive beyond repair? At least as it is I can return it and say that it just stopped working properly!


#3

Did you make sure the drive was empty? I’m wondering if you could “dump” your current firmware then update. I think Binflash has a dump utility.


#4

Try DB binflash and a different firmware such as L&D’s 1.UE or 1.UF. This should allow you to get out of this loop. Dumping won’t remove a firmware, just copy it to HD.


#5

Thankfully I solved the problem. I tried using the Dangerous Brothers Dos utility to flash the firmware from 1.04 to 3.04 but could not seem to get the syntax right no matter what combinations I tried. The closest I could come was a message telling me to specify the Firmware file to upload. The syntax I used was: ‘nec3520A –sec –sla –flash 3520ORIG.BIN’. This was telling the computer to update the firmware on the NEC3520a which was a secondary slave and to use the BIN file 3520ORIG.BIN but it would not work no matter what spacing I used. I wish the people that made these utilities realised that we are not all experts at Dos. I consider myself reasonably computer literate but I could not do it.

When that failed I then decided to switch the drive to another computer and try to flash from Windows again. I decided to try this because at the NEC site where I got the 3.04 Firmware it said it would not work from Windows if you had Intel Application Accelerator installed. I did not think it was installed but I do remember installing it a long time ago and then realising it was not suitable for my computer and uninstalling it. I did however have other Intel stuff installed for the onboard ethernet and wandered if the Intel software interfered with the flashing.

I put the drive in another older computer which had Windows XP installed but no ethernet or Intel software and when I attempted to flash from Windows instead of the error message and light on the drive continuously flashing to my joy it updated the Firmware to the official NEC 3.04.

I won’t be flashing firmwares again for a while until the memory of this ghastly experience is dim. I didn’t even backup the old Firmware as I was confident that updating the firmware was a simple procedure which I had already done a few times on other drives without a hitch. Now I know it is not so simple and not to be taken lightly.

Thanks for the suggestions guys.