Nec3520 slow read/burning

vbimport

#1

Hey Y’all!

I recently bought a nec3520a and flashed it with liggy/dee’s patched/hacked beta 2 firmware but I get really sucky burn speeds with it.

I cant get higher burnspeeds then 8.3 with Memorex dvd-r 8x
media code: CMC MAG. AE1. When I try to burn it with 12x burnspeed & device buffer goes up and down almost all the time and the device keeps spining up. Same story with 8x.

I rolledback with different firmware couple times but no luck.
I checked with Nero cd/dvd speed couple times I cant get higher readingspeeds then 9.22. I check if dma was on and it was on.

Can anyone tell what I do wrong?


#2

If you are copying on the fly then your burn speeds are unlikely to reach 12x without the buffer leaping up and down. Same applies to 8x if your reader drive can’t read fast enough. To copy on the fly at 8x, your reader needs to be able to read at a constant 10x or better, and not many readers can do that from DVD-/+R media. Also, your reader and burner would need to be on separate IDE cables/ports.

If you are burning from your hard drive, you should be able to burn at 12x, assuming your hard drive has fast enough data transfer speed, and ideally the hard drive and burner should be on separate cables/ports, more so if the hard drive is a little slow reading.

If the problem is none of the above, then make sure DMA is enabled for all drives/IDE ports. If not, then the data transfer rate will be much much slower than it should be.


#3

DMA is on but on multi-word dma mode 2 so thats the prob
Tried everything, drivers change,fresh xp install,register change
but still not worked just tried it at work and it works!!
So kinda glad so this means its a mobo prob GA-7zx
which sucks ass!!