Nec3500ag stuck on PIO - i tried EVERYTHING

vbimport

#1

okay so i got this drive a few years back and never really used it. when i did it was insanely slow but i just kind of accepted it. now i want to use it and can’t get it off PIO mode, which is probably why it was always so slow to begin with. i tried EVERYTHING suggested in every thread on every forum. it rips DVDs insanely slow (2.0x). i tried a few firmware fixes that supposedly take the lock off but still…nothing. also, now my PC lags whenever i try to watch a DVD and it burns DVDs insanely slow…because it’s stuck in PIO mode. the drive reads data discs and music CDs fine.

when i go into device manager/drive/properties/advanced settings the transfer mode is ALWAYS set to transfer mode: DMA Mode if available Current transfer mode: PIO Only… no matter what i do.

I’m using XP SP3 (i should of never installed SP3 btw).

things I’ve tried:

deleted drive in device manager and restarted
put setting to PIO mode only, restart, put DMA if available…restart…still won’t go to DMA mode.
checked/replaced jumper
edited registry
checked/changed ide cables - switched them around every way imaginable including putting it as the primary on both channels. i only have 1 other drive (hdd) that is using sata so both ide channels are empty except for the nec3500ag - no other conflicts.
updated chipset drivers
various firmware fixes
tried ripping/playing different dvds

and i probably forgot to list other things i did to try and solve it, but for the most part…that’s it. i’m about to destroy this thing with a sledgehammer.

the only thing i could think of that i didn’t do was a BIOS update. my bios version is way outdated but i don’t want to mess with it unless totally necessary. i had no problems before playing DVDs with this…now even thats slow so it worked fine with the bios AS IS in the past. also, when i go into the bios and check IDE settings…there’s not many options for DMA and you can only select “AUTO” or “DISABLE”. another thing…the driver being used for the drive is a microsoft driver from 2001, and when i try and update it to another driver, it says the windows driver is the best driver to use and no other drivers are necessary.

anyone else have any idea what it could be?

system: AMD 3500+ (2.21ghz), Foxconn 6150K8MA-8EKRS mobo. nforce 430 chipset. 512 mb of ram (i know it’s not alot- i recall watching DVDs fine on this computer before though. i recently formatted my PC and this is when the lag problems playing DVDs started, never mind the insanely slow ripping- i suspect it has something to do with SP3.)

thanks in advance.