Nec2510 read errors +RW (even straight after formatting)

Hi,

Just purchased new ND-2510a. However, getting read errors when reading data that has been written to a +RW. Initially used Roxio’s Drag And Drop program but when getting read errors from that I unistalled and tried just using windows own on another disc. This still caused errors. Tried fully formatting another disc using ‘dvdinfo’ but when i scanned immediately after I was still getting read errors. Also on each disc I noticed that there was speckled marks appearing, which where more dense towards the outer edge (never burnt dvd’s before so not sure if this is ‘normal’ ).
Below is the disc info from ‘dvdinfo’:

Region information N/A not a DVD-VIDEO
Media code/Manufacturer ID PRODISC W01
Media Product Revision Number 02h
Book Type DVD+RW
Media Type DVD+RW
Media Id Code Speed 2.4x 3324KBps
Available Write Descriptor CLV 2.4x 3324KBps
BG Format Status Completed
Data area starting sector 30000h
Data area end sector 23053Fh
Linear Density 0.267um/bit
Track Density 0.74um/track
Number of Layers 1

Is this a problem with the discs, me or the writer? Please advise. (Haven’t tried writing to a +R disc yet).

Cheers :bow:

speckles or irregular markings on the writing surface is definitely not normal.
you have a defective disc.

Could the speckles not be a result of a defective writer?

It is possible, but more likely that just the specific disc is bad.
Have you burned any other discs yet?

I’ve burnt an audio cd which played back fine on the hi-fi. But otherwise no, just the 3 DVDRW’s. Will probably try a +R later today.

Cheers