NEC won't work in DMA 2 mode

vbimport

#1

I was having the PIO problems in XP, unistalled and installed the IDE controllers in device manager. When ever it goes to DMA 2, eventually windows will force it back to PIO.

So I did the registry tweaks from this thread:
http://club.cdfreaks.com/showthread.php?s=&threadid=60218

When the IDE channel is manually forced to DMA 2, the NEC drive won’t work. If I insert a disc, and the PC just hangs, won’t read disc or anything. If I undo the Registry tweaks, and allow the IDE controller to go back to PIO, then the drive works again.

What gives?


#2

Sounds like XP is detecting errors at the higher speeds. Try a higher quality 80pin (not cheap 40pin) shorter cable and try the NEC drive by itself as a master at the end of the 80pin EIDE cable.


#3

I have it on an 80pin cable now as master, even tried adding another drive on there and setting NEC to slave. When I uninstall and install the IDE port, and goes to DMA 2, the NEC just freezes when you put in a DVD or a cd and try to read it. The second DVDr works fine though. :confused:

I’ll try swapping out with a new cable tonight, but the NEC only seems to like it in PIO mode?

My setup is a P4 3.4, 1GB ram, 36GB raptor, 160GB hitachi. NEC only burns at 1.8x on the raptor and the hitachi, I’ve narrowed it down to the PIO-DMA problem, but when I manually force DMA 2 mode in the registry the NEC just freezes. Only works when you allow XP to force it back to PIO mode.


#4

You didn’t say which NEC drive. My 2510 does DMA 2 ok on a SIS746FX chipset motherboard if that helps. Are there any updated motherboard chipset drivers you could try, or even Microsoft ones?


#5

Go into the BIOS under the NEC and set detection to AUTO. Do you have a DELL?


#6

NEC 3520, on an intel D915PBL mobo. It’s not a Dell. I’ve set mobo to auto detection, installed reinstalled drives, etc. Haven’t updated the mobo yet, but will try that tonight, along with a new IDE cable. Hopefully I’ll have some time since it’s vday, but this problem must be resolved. lol :stuck_out_tongue: I’ve spent probably 10-12 hours already on this looking for a solution.


#7

Did you deleted BOTH IDE CHANNELS in Device Manager? How about a clean install of WXP with only the NEC connected to the Master Secondary IDE channel. WXP should detect the NEC with DMA mode 2.


#8

Hmm, you say so, furballi

I think topic poster will have a hard time to delete two IDE-channels, because there is only ONE!

@slicks2k, d/l intel chipset drivers and also other drivers needed.
I don’t think M$ XP is able to set up the newest mobos in a correct way… My 0.02$.

BTW how are your HDD’s connected?


#9

Did the intel updates yesterday, uninstalled, and installed the IDE channel again. When XP reinstalls, it is set to DMA 2 on the master (NEC), and DMA 4 for the slave drive, which is a BTC 1008. The NEC still freezes when I try to use it on DMA 2, and won’t work until XP forces it back to PIO. The BTC works on DMA 4 fine.

So I tried switching the NEC to slave and BTC to master, same results. The BTC is DMA 4, but the NEC freezes until forced back to PIO.

My HDD setup is, one Raptor 36GB SATA onboard, and one 160GB hitachi on a Ultra IDE PCI controller. I’ve tried burning from the Raptor and the Hitachi, sames results, 1.8X on the NEC.

Edit: I’ve also tried the NEC by itself on the IDE channel, so having two drives isn’t the issue. I got the same thing, won’t work until forced back into PIO mode. Odd thing, is that the BTC works fine on the same cable, no issues. Weird. :confused:


#10

Retest the NEC WITHOUT the PCI controller card and Hitachi HD…just reload the primary and secondary IDE channels. I know that a clean install of WXP Pro SP1 will automatically detect the NEC 3500. Of course, you have a different motherboard and BIOS.

I use firmware 218btrpc1.


#11

Do you have intel application accelerator enabled? That software can cause a conflict. Got two choices the drive is defective, OR, the mobo can’t properly set up the ide channel due to a conflict of some sort. Is it possible to take the drive and install it in another computer? May tell you if drive is defective.


#12

Intel app accelerator is not installed.

Welp, I’m just about to RMA the drive to newegg, nothing seems to work. I doubt its the Mobo’s IDE channel since the BTC on the same channel set as slave is set to DMA 4 and works fine.

I’ve tried new IDE cable, removing the PCI IDE controller, master slave settings, unistalling installing the drive itself. :confused: :sad: This sucks, I bought the NEC because the BTC had problems, and the NEC is well recommended, but the NEC doesn’t work either. :sad:

I’ll try installing drive in another PC before I RMA as a last resort.


#13

I suspect the NEC will work in another HD. Have seen a similar problem with another drive. Clean install of Windows with the drive attached to the secondary IDE channel fixed the problem. I would also reflash with the stock firmware, just in case you have a bad flash.


#14

Intel P915 only has one IDE channel though, not two. The rest are 4 SATA channels, which one I’m using for the Raptor.

I’ll try the drive in my other PC tonight to see what happens.


#15

Missed that thread. My bad. The famous 915. Try it with a “conventional” MB (two IDE channels) without SATA. Please post your result.


#16

Goods news and bad news, 3520 wouldn’t work on DMA 2 on the second PC either, but at least I know its the drive now. I’ve pretty much done everything I could to troubleshoot, just gonna RMA the sucker now. Thanks for the help everybody.


#17

hey slicks2k, I have exactly the same problem like yours. I’ve tried everything I could but it still doesn’t work, WinXP always forced it back to PIO mode or else it would freeze. I even tried to install a frest new WinXP, change the IDE cable.
I’m pretty sure the drive is fine because I set it up on my friend computer and it worked just fine. And for you information I had this problem with 3 drives : Nec 2500, 3500 and Pioneer 107 (w/ updated firmware and bios drivers, im using Abit IC-7g). This problem has made me want to build a new comp since I can’t stand waiting for 30min to burn 1 dvd.


#18

Sky, so you never resolved either? Well, when I installed in a completely separate PC, it still came up with the DMA problem. Also, this is a brand new comp, all parts are a month old, and everything else is working fine. I don’t what else is left to do except RMA and hope the next drive works?


#19

sorry i never resolved the problem. Maybe yours has some problems with it, i think you should RMA it since it didn’t work on the other comp. Hope someone could help me to fix this problem but it seems that noone knows how :frowning:


#20

Try using the NEC as a slave drive on the Primary IDE on your mobo with your HDD. This worked for someone on the forum when I was researching my problem. If your drive worked correctly on a different PC, it might be your mobo, if you can rma it, then do that.