NEC/optiarc ad7170a stuck at 1x read speed

vbimport

#1

When I try to rip a dvd using dvd decrypter, the drive automatically rips @ 1x speed, but I know the drive itself has a read speed of at least 13x for double layer dvds. I flashed the firmware to rcp1 from your website, http://liggydee.cdfreaks.com/page/en/Optiarc-AD-7170A/
but still nothing. I know dma mode is enabled, but I thought that even at pso it would read @ 3x or something. Any solutions?

Thanks in advance.


#2

bump?


#3

no one? Cmon!


#4

please, must fix this problem.


#5

What’s the Burst Rate.


#6

I don’t have nero, how would I determine the burst speed?
Thanks for the post man!


#7

What is the read speed set to in DVDDecrypter? Tools > Settings > Device.

BTW CDSpeed utility can be downloaded for free from their website.


#8

I set it as max, but I’ve also tried all the manual speeds and every time it’s stuck @ 1x. Thanks for the link.


#9

Have you checked that DMA is enabled for the drive? :slight_smile:


#10

According to acegazda dma is on. (I guess that pso, should be pio mode).

A Burst Rate test, would give the answer if the Optiarc is in pio or dma mode.

Your dma settings should be ‘DMA, if available’ and below ‘Ultra DMA mode 2’.


#11

i’ll run the burst test and confirm. thanks


#12

alright, I ran the test and the burst rate is 1mb. I’m guessing that is bad. How do I increase it to 44 like the one you posted? The specs of the burner say the rate should be 66mb/s max.


#13

Either the connection/mobo or the drive itself is bad.

Test it in another computer.


#14

Either you’ve not enabled DMA properly (most likely), the drivers for your IDE device are not installed correctly, or you’ve got a serious hardware issue.

The first two can be fixed by uninstalling the main IDE controller in Windows device manager & rebooting, forcing windows to redetect the controller and all devices.

The last thought occurs to me … you aren’t benching with a copy-protected DVD are you?


#15

I was benching with nfs: carbon.
How do you “force” windows to recognize the ide controller? Doesn’t it do it automatically?


#16

Windows will keep doing the wrong thing, as long as you don’t tell it otherwise.
If you tell it otherwise (by uninstalling the existing IDE device drivers) it will be forced to look again & do the right thing, probably (install a working copy of the IDE device drivers).


#17

I just realized that when you said “ultra dma mode 2” it says n/a in that space for me. perhaps that’s part of the problem. I’ll uninstall the ide controller.


#18

I uninstalled the ide controller, and nothing changed. This is kind of ridiculous… the drive’s specs are definetly 16x read for dvds.


#19

You must uninstall the main IDE controller, not the primary or secondary channel.


#20

ahhh… thanks. I’ll try again.:smiley:

EDIT: is that the “standard dual pci controller”?