NEC ND2500a reading/ripping problems

vbimport

#1

I bought this 8x DVD burner (OEM) from newegg.com a few months ago, but I’ve had problems with it for a while now (i just keep not doing anything about it).

I admit, and this is probably the cause of the problem, I flashed the firmware to the rip-hack when I first got the drive (so i could rip at 8x rather than 2x).

I tried flashing back to 1.05 firmware factory drivers, but that didnt do anything (all i did was find the 1.05 firmware, flashed it, and restarted).

It rarely has problems burning DVDs, but where it is failing badly is in ripping and reading dvds. Most of the time it’ll fail to rip a dvd that another system in my home can do without a problem. But now it wont even read DVD or Cd’s very well at all. For instance, I just bought The Iron Giant DVD, and when I try to play it it says in an invalid format…? It does this with a lot of DVDS, and while the dvd is in there, the computer is drastically slow. I can barely do anything while it freezes up, I take out the DVD and its back to normal.

Anyone know the cause of this and a possible solution? Could I RMA this back to newegg or is that voided due to the firmware thing?


#2

Are you saying that you cannot reflash to one of the older factory firmware? Ever try flashing in DOS?


#3

i did, i flashed it back to the latest 1.91 firmware and nothing.

I’ve never tried flashing in dos, can you in win xp?