NEC ND1300A Extrenal USB2, problems

First of all, Hi there. Glad I found this forum.
I have some problems with a external ND1300A, it’s a One AluWriter with USB2.0 interface.
I’ve searched this forum and found out that the Nec 1300A is a little tricky regarding to the media you can use but I’ve also found out that it should work with PRINCO media if you have upgraded the firmware…
So this is what happend… Bought the drive, plugged it in and started burning with DVD Decrypter, first it only recognice the drive as a 2x, so I installed a USB2 driver from one-tech and then it worked. Burned like 20 dvd’s with no problem in 4x (in DVD decrypter, nero6 with updates didn’t work). Thet it seemed as the speed was dropping… Frst it still worked but only in 2x, then it didn’t worked at all!
Nero report “reset occured” and DVD decrypter tries to burn the lead-in forever.
What’s this? Can it be the media? It worked for a start! Can it be diffrent quality on the media? Or has the burner died?
It works fine with cd-r… Haven’t tried dvd+r, only dvd-r.
Reinstalled ASPI (and tried the trick to use one of four drivers from Nero), USB drivers…

Test-write works in Nero and DVD-decrypter… But not the real thing.

System:
WinXP pro
Abit IT7 mb
Raid 0 hd:s (intenal raid on mb)
Pioneer xxx dvd-rom on IDE 0
Plextor 40x cd-r/rw on IDE0
One-tech AluWriter USB2.0 with NB1300A, firmware 1.08

Media:
Datawrite 4x (yellow) manufácturer: PRINCO

Sorry for the long post…
//Moe