NEC ND-7550A and Reverse ATA firmware

vbimport

#1

Hello, all!
I have a question (maybe few questions). I just bought new ND-7550A and I have a problem with master/slave conflict on Compaq Armada 1750 notebook. It uses only one IDE channel. When both HDD and DVD drive are connected, the computer will not boot up. I tried to connect the pin 47 to GND or leave it opened, but it doesn’t help:-( (it is strange, isn’t it?). So it seems, I have to use Reverse ATA Firmware.
I wanna know, if it is possible firstly dump curent fw version, use reverse ATA and sometimes in the future use the previously dumped firmware (I mean in case I will need back standard ATA function).
And other question - will be reverse ata firmware functional in my case?
Thank you very much for your replies.

Bye, Martin


#2

Dumping the main firmware should be possible - the bootcode is not dumpable with public tools. But I already have master and slave bootcode for this drive, so there’s no need to back it up.

Normal ATA package is available, but it’s not public either. If someone needs it, just drop me a message.


#3

Hey WTF, the master/slave/csell is decided by the firmware in notebook drives? :confused:


#4

ALWAYS!


#5

At least I haven’t seen master/slave/csel jumpers on these drives


#6

Thanks Liggy.
You know, I tried to play with the drive again today and I found, that system still recognize it as a master. Connected pin 47 to ground or left it open has no effect:-( (can be this caused, that the drive was on the channel alone?).
Do you agree with me, that only reverse ATA firmware help? I am going to buy a slim/IDE adapter tomorrow.


#7

It’s very hard to tell what exactly is going to help and it mostly depends on how the laptop handles IDE connections. The best solution always seems to be having a laptop that needs an optical drive set to master I think.


#8

Hmm, I just saw my Panasonic 6X DVD-ROM SR-8174 has a jumper. :bigsmile:


#9

And I have to admit that I only know NEC slimline drives :bigsmile:


#10

Yes, you’re right. But the laptop is the first thing, which you buy, and the drive is the second:-) You never buy the drive first and then the laptop:-)
I think, that the problem is, that my laptop wants always HDD to be a master (only my opinion, not fact, I don’t know how to check it). And if it has only one IDE channel, the drive must be only a slave.


#11

Every Laptop should support either Master or a Slave device. It’s just not easy to find out before actually having a drive.


#12

Hello smidliboy
I just have the same problem, ND-7750A don’t work with my toshiba laptop and I connected the pin 47 to GND with no effect :a
I have buying a slim/IDE adapter on ebay and waiting for it, hope it’s not too difficult to do the reverse ata :rolleyes:


#13

Hi, wolfen,
I did it today and it works! Don’t be afraid, just follow the Liggy’s guide.
God bless you, Liggy:-)


#14

Are we talking about nd-7550a or nd-7750a? I checked the web site and there seems a 7750a exits, just not for sale in US. Any information about 7750a?


#15

I guess 7750 is just a typing error. I don’t think such a drive exists. Fixed thread title


#16

Yes, It is just a typing error. See my first post, there is a correct title. I am sorry!


#17

see:
http://www.nec-cebit.com/en/press/latest/latestnews.html?func=full&id=44

and

http://www.gaz.co.jp/parts/t2_175/t2_175m8.html

typo?


#18

On their German language CeBIT page it’s called 7550/7551 again. Maybe they first wanted to call it 7750 but later decided for 7550


#19

Well, the 7550/7551 wasn’t the first drive listed with a typo somewhere. Over here (Germany) there had been shops selling a Nec 6550A, but from what I know, there wasn’t such a drive, just a 6500A and the 6650A…

Anyways, I’ve another question, but don’t want to open a new thread… @Liggy: In the firmware thread (Overview for different NEC firmwares) under the 7550A 1.01 firmware there was the RICOHJPNW21 media code listed. When I looked up this code in the MCSE software, I didn’t found that code. Plus, what makes me feel MCSE is correct, my 7550A refuses to burn this media (power calibration error). Where do you get those listings from?


#20

This listing is generated by a self written tool that Wendy and I use for modifying firmwares. Since every firmware needs a manually generated ini file, something may be wrong of course. But here’s a CD-Speed scan of a RICOHJPNW21 from a 7551 (same hardware) with firmware 1-02