NEC ND-6750A and HP Paviliion DV4040

My 3 year old ruined the drive in my laptop last Christmas.

I ordered a NEC 6750 from Newegg. Windows recognised the drive and was able to eject it so I thought the problem was fixed until I tried to use the drive. It was very sluggish/non-responsive. I could read the contents of a disk but it could take 5 minutes to pull the directory contents and forget about executing programs.

I found the forum and Liggy and Dee’s page. I ordered a slim adapter from Directron and hooked it up to my desktop to flash the drive.

I used the NEC ND6750A Slave bootcode flasher, rebooted, then the Binflash Win32 GUI with the NEC ND6750 Firmware 2.T2 firmware, rebooted.

The drive worked perfectly in my desktop. Once placed back into the laptop with the new bootcode the IDE controller became non-responsive and the laptop won’t boot at all.

To sum up

  1. factory default/master setting the laptop boots and drive is recognised but unusable
  2. set to slave the laptop won’t boot.
  3. the drive works fine on a slim ATA adapter in my desktop as either master or slave

I have tried to read up as much as possible and did some searches on the forum to try to find someone else who had this problem but I haven’t found a suggestion of what to try next.

Does anyone have a suggestion?

Thanks!
-Matt-

First you have no option, except to use the drive with master bootcode and corresponding master firmware. I use 2.42 with quality media like Verbatim and all is fine.

Thanks for the help TQHoang. I am not soo worried about writing disks but even reading them. The OEM drive was also a NEC, it makes me think there has to be a setting that is off.

Could someone else please suggest another fix? I could order another drive perhaps? Could someone suggest a slim drive that should work with the laptop for certain? HP support on this was not useful as you can imagine.

Thanks!
-Matt-

What kind of disc are you trying to use in it? Does it have errors?..NEC drives don’t typically have a great reputation as good readers…just really good writers.

ANY disc I put it in. Music CD, Game CD, CD with autoplay, CD without autoplay. It won’t properly read. When I insert a disk the little CD icon will appear next to the cursor, and ~5 minutes later the pif icon for the disc will change in explorer. I can wait 20 minutes after selecting the drive in explorer to get a directory listing, and can forget about actually launching anything with it.

Again though, the drive works flawlessly on the adapter when connected to my desktop.