NEC ND-6650A drive not working anymore

vbimport

#1

Hi everyone,

Just a few weeks ago I installed Registry Mechanic on my computer and set it to clean my c: drive. I think that during that process, I deleted something related to my NEC drive. I can no longer read or write anything. I tried restoring my system but that didn’t do any good. I also tried installing the 103c firmware and no luck there.

If anybody has a solution or suggestion, it would be greatly appreciated.
Thanks, David


#2

Welcome to cdfreaks. :slight_smile:

Is your drive properly recognized in BIOS and/or devicemanager?
(Depending of the brand of your laptop, you can boot into BIOS directly at start-up of compu with F2, F10, Del, aso. You’ll have to try it out. Don’t change anything there atm).

Try also to boot from your windows (or Linux distro) installation cd.
(If drive doesn’t start loading check in BIOS that your drive is in boot chain, under “boot option/devices”.)

BTW, registry tools should be used with precaution and only by experienced users. :wink:


#3

I own a dell inspiron 6000 and I don’t have the windows installation disk. I know that my drive is in my device manager but I wasn’t able to update the driver through windows. I don’t know if that changes anything…

I found that Registry Mechanics improved my computers speed significantly and I would like to know things about it so I can continue using it; what would you recommend for settings when I scan (i.e. folders to scan and whatnot).

Thanks for you help, D


#4

All optical drivers needed are included in windoze. Have you checked drives status in devicemanager.
BTW, you better get a windoze installation disc, just in case things get worse.

Sorry, don’t know anything about Registry Mechanic.
I’ve been using Jouni Vuorio’s RegCleaner (freeware) for years now without an issue. :wink: