NEC ND 6650 Instal problems, please help

Hi guys just found this site and I have to say its a great tool.

Here’s my problem.

I purchased a NEC ND6650 from New egg this week. I got the drive last night removed the original drive from my Dell Inspiron 8600 and put in the NEC. Now windows was taking forever after the reboot. I then went into safe mode and tried to install the hardware. The one problem is that my computer recognizes it only as a cd rom drive. Not a dvd burner. But even when I put a cd in the drive it won’t play. I’ve tried everything that I could think of to install this correctly. I’m close to just taking the drive back out and putting my original back in.

Any help with this would be appreciated.

Thanks
Jason

Welcome to CDFreaks. :slight_smile:

Looks like your drive is not properly recognized by Windoze system.
Another possibility is you have “primary” firmware when it should be “secondary”, or vice versa. But don’t start flashing the first thing you do. It’s more to it.

First try this.
Rightclick My Computer --> Systen Properties --> Harware -->DeviceManager, expand (click “+”) IDE ATA/ATAPI Controlers, rightclick on Primary IDE Channel and click “uninstall”. Rebote and reboot again when asked.

Then download Nero InfoTool and check your drives properties, like model, firmware, capabilities aso.

Note. Post images with .png extention. :wink:


I have installed Nec 6550/newwegg/on my Dell 8600.Went smooth right from the box.No reversing master slave req.Windows reconaised as DVD-RW without a problem :iagree: